WordPress.org

Support

Support » Plugins and Hacks » Charset encoding error when duplicating files with Swedish letters ÅÄÖ

Charset encoding error when duplicating files with Swedish letters ÅÄÖ

  • chrillefkr
    Member

    @chrillefkr

    When duplicating my website ÅÄÖ and åäö in filenames are not correct. Instead they appear as bjöörns-cykel.jpg instead of bjöörns-cykel.jpg. This is a big issue when working with Swedish filenames, or any other language with non-English, or as i think it’s called, latin letters.

    https://wordpress.org/plugins/duplicator/

Viewing 9 replies - 1 through 9 (of 9 total)
  • ninjacolin
    Member

    @ninjacolin

    Same for Russian. 🙁

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Maybe its something with the ZipArchive class, I’ll have to do some research on this…

    chrillefkr
    Member

    @chrillefkr

    Thank you! If there’s someway I could help you, just tell me!

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Hey Chrillefkr,

    If you know how to code or someone that does it will probably get done much faster as I have a pretty big todo list right now… Here is the repository for where contributions can be made

    GitHub: https://github.com/lifeinthegrid/duplicator

    Cheers~

    webaware
    Participant

    @webaware

    You are probably pulling from a Linux hosting to a Windows PC. On Windows, PHP can’t handle UTF-8 encoded filenames correctly — it’s a limitation of PHP, and why people say that PHP doesn’t really do Unicode (and why the much vaunted, never delivered PHP6 is supposed to be “the saviour”)

    See http://stackoverflow.com/a/1887617/911083

    cheers,
    Ross

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Yeah PHP is a strange beast that is for sure… Thanks for that update @webaware

    Cheers~

    Swedish – After 2 days of messing i solved it thrue phpadmin.

    I had this problem for all my migrations due to the swedish letters åäö missing in both the menu and product names. (i never use åäö in images)

    Some strange way i noticed in the log file from Duplicator Installer process that it said that the database server used latin1 as charset but as I could see it was utf8. I changed it to utf8mb4_general_ci in “Generall settings” in phpMyAdmin for the _db just to be sure and now all works like a Charm. The migration is a 100% clone 😀

    Duplicator has saved me so many hours of work so heads up to you guys.

    villevetela
    Member

    @villevetela

    are3na, do you have Linux or Windows in your local machine? I have tried meny combinations, but this just doesn’t work for me. I just try utf8mb4_general_ci in both databases, but no luck…

    Villevetela-
    Local machine is Windows and I have provider Loopia.

    Forogt to tell that in the .zip packade you probably need to edit the database file because there is 1 line that has CHARSET=latin1 instead of CHARSET=utf8 as the rest has. Open the zip file and just take the sql file and open it with notpad++ and edit the line and the put it back in the .zip file again. Then do the process as normal…

    Hope this really turn out well for you cause its a mess

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Charset encoding error when duplicating files with Swedish letters ÅÄÖ’ is closed to new replies.