Support » Plugin: All In One WP Security & Firewall » Character String Filters Break Jetpack Slideshow

  • Resolved jjbte

    (@jjbte)


    This is just an FYI for anyone using this plugin and also using Jetpack. I tried to add a Jetpack slideshow to a post on my site. In the editor, the following message appeared: “The Swiper library could not be loaded.”

    On the front end, the slideshow images were displayed in a vertical stack.

    I opened the Developer Tools console and saw the following:
    Failed to load resource: the server responded with a status of 403 () for plugins/jetpack/_inc/blocks/vendors~swiper.cf8591a6825782c29597.js
    Failed to load resource: the server responded with a status of 403 () for plugins/jetpack/_inc/blocks/vendors~swiper.cf8591a6825782c29597.css

    I realized this was most likely due to the bad character filters I had enabled since the blocked files contain the ~ character in their filenames. I had to disable the Advanced Character String Filter and the 6G Firewall Protection for the Jetpack slideshow to work.

    Another option would be to keep these filters enabled, but manually edit the .htaccess file to remove references to the ~ character. This would need to be repeated any time the plugin’s settings are updated.

    I don’t know why Jetpack is using filenames containing the ~ character since it is considered an unsafe character. I plan to report this issue via the Jetpack forum as well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, thank you for sharing this information.

    Another option would be to keep these filters enabled, but manually edit the .htaccess file to remove references to the ~ character. This would need to be repeated any time the plugin’s settings are updated.

    A better solution is to enable Enable Custom .htaccess Rules . This is located under WP Security -> Firewall -> Custom Rules. By using this feature, you don’t have to repeat these steps every time the plugin is updated.

    Kind regards

    Thanks. I always forget about the custom option for some reason. So temporarily enable the filters and find their sections in the .htaccess file, remove all references to the ~ character, copy the result to the Custom area, then disable the filters.

    I reported this issue via the Jetpack forum. I’m hoping they’ll address it so this won’t even be a worry.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.