WordPress.org

Support

Support » How-To and Troubleshooting » Character Set Not Working After Upgrade

Character Set Not Working After Upgrade

  • I had to move my blog within Laughing Squid to the cloud servers and while doing so upgraded WP as well (my blog is here: http://www.sarapci.com) and along the way all my Turkish characters in blog posts have turned to “?”

    When I correct a post from the WP edit page and press “update” the corrected character turns into a ? again.

    I’m not sure if this is a WordPress or a Laughing Squid database migration problem.

    My config file is still set to utf8.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’d think it’s the server/database personally. Your config file may be utf8, but what’s the db charset?

    I think you’re spot on!

    From phpmyadmin I see that collation is latin1_swedish_ci. I’ve no idea how that happened?

    Do you think it’s be corrected if I manually change each table (from phpmyadmin) to utf8-general?

    I wish it was that easy. latin1 is the tragic default of MySQL so it’s not your fault at all.

    Read http://codex.wordpress.org/Converting_Database_Character_Sets

    There was a plugin I remember using back in … Uh… WP 2.6 era?

    I had a problem with Turkish characters not displaying on my hosted WordPress web site and my web host tech support staff and I went through several versions of my trouble ticket before I got it straightened out.

    By this time I had a mess in MySQL so I used:
    phpMyAdmin >> localhost >> Settings and selected “Reset”
    (You can reset all your settings and restore them to default values.)
    ————————————
    NO CHANGES were made to .htaccess
    ————————————
    I changed one item using File manager >> /www >> wp-config.php:

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    ***WE CHANGED DB_COLLATE:***
    define('DB_COLLATE', 'utf8');
    ————————————
    In WordPress we changed the character encoding (to UTF-8) in the dashboard:
    Settings >> Reading “Encoding for pages and feeds” UTF-8

    Greetings. I am having the same problem on my site, but the solutions suggested here aren’t working for me. I build the site initially on my home server and then moved everything over to a public server and a fresh installation/upgrade of WP. Now most (not all) of my Turkish characters are coming up “?”.

    I checked the SQL DB and the collation is set to “UTF-8_general_ci” – I tried changing this to UTF-8_turkish_ci and that didn’t help. I tried inserting utf8 into the COLLATE line in wp-config.php and nothing there either.

    Does anyone have any other advice? I’m at a loss now. Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Character Set Not Working After Upgrade’ is closed to new replies.