Support » Plugin: Minify HTML » Character error in content

  • Resolved Veja.site

    (@danielambrosio)


    Very good this Minify HTML plugin but it is giving character error in my blog when active it the letter (à) stays like this (�) why? Version 4.7.2 of my wordpress blog.

    • This topic was modified 2 years, 11 months ago by Veja.site.
Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Tim Eckel

    (@teckel)

    That sounds like a character set (charset) issue. Looking at your site (and duplicating the html locally) I can reproduce what you’re seeing.

    I believe I have it sorted out. It has to do with non-English characters being multi-byte.

    I’ll be releasing v1.95 tonight. If you could try it out and let me know if it’s working that would be great.

    Tim

    Veja.site

    (@danielambrosio)

    Hello tim

    Okay, I’m waiting for v1.95 for me to take the test.

    Thanks Daniel
    http://veja.site

    Plugin Author Tim Eckel

    (@teckel)

    v1.95 is ready to go. Let me know if it works.

    Veja.site

    (@danielambrosio)

    Hello Tim,

    It was nice to have the detail of the error in the characters.

    I just get one more little detail in the code in the page footer of the two contact code of the contact-form-7 plugin script.

    Hey, I already tried a direct plugin in the plugin but I can not.

    You know how to get this?

    See the image: http://veja.site/codigo.png

    See in the html code of my site in the footer.
    http://veja.site/

    Thank you very, very good, your work, my congratulations.

    Regards,

    Daniel Ambrosio
    http://veja.site/

    Plugin Author Tim Eckel

    (@teckel)

    That’s not an error, it’s doing that on purpose.

    For inline JavaScript it minifies it, but does leave some returns to avoid certain problems and keep the speed fast. As most sites contain little to no inline JavaScript, this is a minor issue. It’s not something that will be “fixed” as fixing it can cause isolated issues (or significantly slower speed).

    In any case, it’s working properly and what you are seeing is correct.

    Tim

    Plugin Author Tim Eckel

    (@teckel)

    Oh, and consider turning on the following Minify HTML options:

    Remove XHTML closing tags from HTML5 void elements
    Remove relative domain from internal URLs
    Remove schemes (HTTP: and HTTPS:) from all URLs

    This will save far more than the 2 enters due to the inline JavaScript.

    Tim

    Veja.site

    (@danielambrosio)

    I was able to remove the contact-form-7 plugin script and manually put it and ta perfect.
    <script type=’text/javascript’>
    var _wpcf7 = {“recaptcha”:{“messages”:{“empty”:”Por favor, verifique se voc\u00ea n\u00e3o \u00e9 um rob\u00f4.”}}};
    </script>

    Plus I updated version v1.96 and the character error back see: http://veja.site/

    É resistente � água, respingos e poeira e nova tela Retina HD.

    Plugin Author Tim Eckel

    (@teckel)

    There was nothing wrong with a couple extra returns in your source (by design), but glad you sorted things out. Turning on the Minify HTML options below will make your HTML much shorter:

    Remove XHTML closing tags from HTML5 void elements
    Remove relative domain from internal URLs
    Remove schemes (HTTP: and HTTPS:) from all URLs

    v1.95 was the one you wanted as it worked correctly with multi-byte foreign characters. v1.96 backed out the function because it caused errors with English websites. Basically, you should have kept version 1.95. In a future release I’ll need to make it an option so it will work both for non-English and English websites.

    If you want to manually fix v1.96 to work with your site, edit the plugin, find the comment “Make this an option in a future release” and uncomment the next two lines (remove the // from each). It will then look like the following:

    	// Make this an option in a future release
    	if ( mb_detect_encoding($buffer, 'UTF-8', true) )
    		$mod = '/u';

    Tim

    Plugin Author Tim Eckel

    (@teckel)

    Version 1.97 will be released tonight which will support a switch for multi-byte utf-8 character encoding for foreign character support. This option will fix your odd characters introduced by the preg_replace when minimizing.

    Let me know how version 1.97 works!

    Tim

    Veja.site

    (@danielambrosio)

    Perfect for Version 1.97 running perfectly fine. Very good thank you!

    Regards,

    Daniel Ambrosio
    http://veja.site

    Veja.site

    (@danielambrosio)

    It is still giving character error (�) in my blog in its plugin Minify HTML version 1.98 Version 4.8 of my wordpress blog.

    Regards,

    Daniel Ambrosio
    http://veja.site

    Plugin Author Tim Eckel

    (@teckel)

    This is because of the foreign language characters on your website and the character set selected. There’s a setting to adjust this that you can try. But, it also may just be impossible because making it work for you will break every English language website.

    Veja.site

    (@danielambrosio)

    Now it’s working perfect had I missing the option> Support multi-byte UTF-8 encoding (if you see odd characters)

    Plugin Author Tim Eckel

    (@teckel)

    Perfect! I had to make it an option because by default it would mess up some English websites. Glad it’s working for you!

    Veja.site

    (@danielambrosio)

    Hello you do not create affiliate plugin requested by user?

    Do I need an affiliate plugin?

    Do you charge me how to create a plugin for me?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Character error in content’ is closed to new replies.