Support » Fixing WordPress » Character encoding issue when changing site url (on Azure)

  • Resolved thestorm042

    (@thestorm042)


    I am hosting a WordPress site using Azure (with mySQL by clearDB), which can be found here:
    http://parkwayplace.azurewebsites.net/

    Everything looks fine, and it works with my custom domains, such as:
    http://www.parkwayplaceevents.com/

    (redirecting from the latter to the former)

    Great!

    However, when I change the “Site Address (URL)” setting (in General Settings) so that the user ends up at the latter URL, then I get some character encoding issues. (specifically, the Facebook, etc. logos in the upper right turn into squares)

    I have read about utf8 vs utf8mb4 and believe my database is set to utf8. This sounds like the problem but I admit I was a little hesitant to follow the various directions I’ve found for updating my DB to utf8mb4; just a little beyond my current understanding.

    Having said all that — if the DB encoding is the issue, then I can’t imagine why it only manifests when setting a different Site Address. Likewise, since everything displays fine on the initial URL, it leads me to believe that the DB encoding is *not* the issue to begin with.

    Any help in troubleshooting this issue and allowing me to change the redirect target URL without losing the “special” characters would be greatly appreciated.

    Thanks!

Viewing 1 replies (of 1 total)
  • Well, no help from anyone, but I thought I’d report back in case anyone else runs into the issue.

    The problem seems to be the difference between the Site Address (URL) and WordPress Address (URL). Originally, I didn’t change the latter because of scary warnings. But, when I updated that to match the updated Site Address, the encoding issue went away.

    Hope someone else finds this useful in the future!

Viewing 1 replies (of 1 total)
  • The topic ‘Character encoding issue when changing site url (on Azure)’ is closed to new replies.