Support » Plugin: Product Feed PRO for WooCommerce » channel_statics option autoloading must be disabled

  • Resolved negrusti

    (@negrusti)


    Hi,
    channel_statics option autoloading must be disabled. It is 50KB option in our case, and it creates unnecessary stress on the caching system in the high-traffic scenario (50K * 1000 requests/second = 50MB/second traffic to Redis just because of that option).

    Please fix ASAP
    Thanks
    Gregory

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi Gregory,

    Not sure what you are referring to but I do know that our plugin is not compatible with the Redis Object Caching plugin.

    The channel_statics function you are referring to is only loading the channels per country into the options database to be retrieved upon creation of a product feed or when a product feed is being updated. I don’t see how that could be causing loads of traffic.

    I did find this treat you might find related/interesting:
    https://github.com/tillkruss/redis-cache/issues/58

    Best,
    Eva

    Thread Starter negrusti

    (@negrusti)

    your option is set to autoload = yes. Therefore it’s loaded on every request to WordPress, even for pages that have nothing to do with your plugin.

    Thread Starter negrusti

    (@negrusti)

    classes/class-activate.php, line 1782:
    update_option( ‘channel_statics’, $channel_statics, ”, ‘yes’);
    to
    update_option( ‘channel_statics’, $channel_statics, ”, ‘no’);

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi negrusti,

    Thanks for this. We identified some more update_option’s for which this was happening (and not needed). We have just pushed out a new release of the plugin (version 6.0.6) that should solve the issue at hand.

    Could you update the plugin and give it a try?

    All the best,
    Eva

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi,

    Assuming the issue at hand has been resolved and our support is no longer required I am going to close this issue for housekeeping reasons now.

    Do not hesitate to reach out again whenever you need our help.

    All the best,
    Eva

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘channel_statics option autoloading must be disabled’ is closed to new replies.