Support » Plugin: Contact Form 7 » Changing wpcf7_recaptcha_threshold

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Try this:

    add_filter( 'wpcf7_recaptcha_threshold',
    	function( $threshold ) {
    		return 0.30;
    	},
    	10, 1
    );
    bdd

    (@bws-online)

    Thank you. That updated the threshold.

    Problems, though. When I look at the Status section in Flamingo, it’s saying “Spam log: reCAPTCHA score (0.00) is lower than the threshold (0.30).”

    So I set it to 0.0 — and it still didn’t send, and the Status section said “Spam log: reCAPTCHA score (0.00) is lower than the threshold (0.00).”

    1. How do I get messages to send using CF7 and reCAPTCHA in this situation?

    2. If I have to set it to 0, how long does it take before you can raise that and still have messages go through?

    Thanks.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    In many cases of the “reCAPTCHA score (0.00)”, that actually means there is misconfiguration and reCAPTCHA isn’t working on the frontend. Probably the situation described in this post is occurring.

    Contact Form 7 5.1.1

    I’m thinking of giving a different log message for such cases.

    bdd

    (@bws-online)

    Okay, thanks. The site is using Avada theme — how do I determine if it loads JavaScript in the footer area of each page?

    Yes, if it’s a different situation, it should definitely have a different log message.

    bdd

    (@bws-online)

    Any insights please?

    In my case, it was resolved by removing the plugin (or could be setting in your case) that attempted to ‘defer’ or ‘async’ javascript.

    Fixed it instantly.

    WP: 5.2.2
    Recaptcha v3

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.