Support » Fixing WordPress » Changing wp-content from http to https

  • Resolved ligerdub

    (@ligerdub)


    Hi all,

    I had some problems yesterday sorting out the security of my website and enabling access through various web filters. This has now mostly been resolved.

    I still though have some problems with mixed content on the site and I can’t find a way to resolve. TL, DR of the below, I need to change the URL’s of the wp-content of images I’ve uploaded from http to https but can’t do it. Does anyone have any ideas?

    I’m getting the following error message on each page (different urls for the image):

    Mixed Content: The page at ‘https://elyinsights.com/’ was loaded over HTTPS, but requested an insecure image ‘http://elyinsights.com/wp-content/uploads/2018/02/DUBLIN20180212182514-2.jpg’. This content should also be served over HTTPS.

    I can’t seem to find a way to change the URL of the image on the site from http to https. I’ve installed the following plugins but none of them resolve the problem:

    Better Search Replace
    HTTP Headers
    Really Simple SSL
    SSL Insecure Content Fixer
    Wordpress HTTPS

    I’ve pasted the following into the wp-config file

    /** Http Headers – Setup by E Lyons. */
    define(‘FORCE_SSL_ADMIN’, true);
    define(‘WP_HOME’,’https://elyinsights.com’);
    define(‘WP_SITEURL’,’https://elyinsights.com’);

    and this into the .htaccess file:

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.elyinsights.com/$1 [R,L]
    Header set Strict-Transport-Security “max-age=31536000” env=HTTPS

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Do you have any caching plugins? If so, disable them to see if it’s a caching issue.

    NO PLUGINS at all are required for SSL once you’ve run “better search replace”. Note that it’s default is to run in “dry run” mode so it makes no changes.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Also, check your CSS just in case that file is hardcoded someplace in your CSS.

    Thread Starter ligerdub

    (@ligerdub)

    Thanks Steve.

    I’ve checked CSS and no issues there. Plugins don’t seem to be a factor either re: cache.

    I’ve also tried placing the following code in the wp-config file without success:

    define(‘WP_CONTENT_URL’, ‘https://elyinsights.com/wp-content’);

    Is it possible that the Theme I’m using (Ocean WP) could be a factor?

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    I can’t find that image referenced anywhere on your page, so it’s coming in via CSS or javascript.

    Use the plugin ‘string locator‘ and see if you can find it. Search on “DUBLIN”.

    Thread Starter ligerdub

    (@ligerdub)

    Fair play Steve……worked a treat. I was able to find the location where the images were stored. They were part of the media library installed to the page.

    The directory was stored in the following location:

    wp-content/uploads/elementor

    And then in the relevant posts.

    I just went in there and found the various URL’s, and changed them from http to https and I no longer have any mixed content errors.

    Thanks so much!

    Eoghan

    Hi Eoghan
    The Home page link on the main menu at the top and the bottom menu, if you are on the About page, Services page or Contact page it doesn’t go back to the Home page but whatever page you are on.

    Colin

    Thread Starter ligerdub

    (@ligerdub)

    Hi Colin,

    Thanks very much for the heads up, much appreciated. Good spot.

    I’ve disabled some plug-ins, one of which had an impact on the permalinks format. Having made those changes the links look fine now, and the formats and other various content urls appear to be in the right format.

    Thanks again,
    Eoghan

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Changing wp-content from http to https’ is closed to new replies.