Support » Plugin: Appointments » Changing working hours doesn’t affect on schedule table

  • Resolved Pauron

    (@pauron)


    Hello.

    I changed working hours, it had been from 10 till 18, now it should be 9:00 till 18 but the schedule shows 10 till 19. No changes of the working hours affect changes of the frontend schedule. It’s stucked as it was.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @pauron,

    Hope you’re well.

    Did you select any specific provider from “List for:” option?

    If not can you try with selecting provider first?

    Cheers,
    Oguz

    Hi,

    Of course, I chose a provider. No changes are applied – every provider has the same 10am-7pm schedule, but I have set different time for each of them.

    Plugin Contributor Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @pauron,

    hope you’re doing good and really sorry for the late response here.

    I just tried to replicate this in a testing site of mine, with no avail though.

    If I set the “No specific provider” to start at 10AM and I load my “Make an Appointment” page with weekly schedule and no predefined service provider, then available slots start at 10AM.

    If my service providers are set in the Working Hours to start at 9AM though, and I select the service provider from the Service Providers dropdown, then slots are becoming available from 9AM.

    In any case though, weekly schedule starts from 9AM.

    https://monosnap.com/file/ZAzVtjW4D2UhvLw9Ovmb51AaqSJMuK
    https://monosnap.com/file/EMrFpGMFsJwSJqag7ieOAPvt8RK1wM

    As this may have to do with the specific shortcodes you’re using, could you please inform me about these? Just paste them here in your next reply, so I could further troubleshoot. 🙂

    Warm regards,
    Dimitris

    Hi,
    My shortcode is [app_schedule add=”0″ worker=”5″][app_pagination] or [app_schedule add=”1″ worker=”5″][app_pagination].
    Whether I set time to 8am on “No specific provider” or not, the schedule doesn’t change. I just want it to be from 10am on weekdays, and 8am on saturday. It shows from 10am.
    What’s interesting, I can choose 8am on a provider, but in every case the slots show up from 10am. It’s stuck.
    Now I think I tried everything. Please help.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @pauron,

    Hope you’re well.

    When I try your shortcodes, the hours successfully changes for my test site. But if you set one day to 8 am all table days will start at 8 am. Although for weekdays between 8am-10am can’t selectable.

    So is this the same thing for you? You shouldn’t make working hours changes while “No specific provider” selected. You should first select the service provider, then change the hours.

    Here is the screenshot of what I mean;

    As you can see “Friday” shows at 8 am but not selectable. This is because there is no day selector all possible hours should be shown. If you don’t want to show other pages between 8 am – 10 am, maybe monthly schedule is a better choice for you.

    Cheers,
    Oguz

    I did as you said and there’s no effect – starts from 10am whatever I do.
    I consider it can be matter of my hosting, but I am not 100% sure.

    I checked my database and the code for that provider is:

    a:7:{s:6:”Sunday”;a:3:{s:6:”active”;s:2:”no”;s:5:”start”;s:5:”08:00″;s:3:”end”;s:5:”13:00″;}s:6:”Monday”;a:3:{s:6:”active”;s:3:”yes”;s:5:”start”;s:5:”08:00″;s:3:”end”;s:5:”20:00″;}s:7:”Tuesday”;a:3:{s:6:”active”;s:3:”yes”;s:5:”start”;s:5:”10:00″;s:3:”end”;s:5:”18:00″;}s:9:”Wednesday”;a:3:{s:6:”active”;s:3:”yes”;s:5:”start”;s:5:”10:00″;s:3:”end”;s:5:”20:00″;}s:8:”Thursday”;a:3:{s:6:”active”;s:3:”yes”;s:5:”start”;s:5:”10:00″;s:3:”end”;s:5:”18:00″;}s:6:”Friday”;a:3:{s:6:”active”;s:3:”yes”;s:5:”start”;s:5:”10:00″;s:3:”end”;s:5:”18:00″;}s:8:”Saturday”;a:3:{s:6:”active”;s:3:”yes”;s:5:”start”;s:5:”08:00″;s:3:”end”;s:5:”15:00″;}}

    I could replace the values, but I am not sure what is what.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @pauron,

    Hope you’re well.

    The database values you shared doesn’t look like has the problem. There is already start times 08:00 so it should show before 10:00. Can you try plugin and theme conflict test?

    You need to deactivate all plugins and leave only Appointments active, change your theme to Twenty Seventeen and test again. But because of this can cause data loss I recommend to take the backup or try that on staging site.

    Also, can you share screenshots of Working Hours options?

    Cheers,
    Oguz

    Hey Oguz,

    I deactivated all my plugins and reverted to Twenty Fourteen theme, and there’s no changes. It’s stuck ;{

    I even reverted site to non-SSL mode.

    It still starts from 10am.

    My working hours options:
    https://trychologia-slask.pl/wp-content/uploads/2018/06/grafik-opcje-pazia.png

    Cheers,
    Pauron

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @pauron,

    Hope you’re well.

    This seems really interesting because I can’t replicate it in any case. By the way, you are sure not using any cache system, right? Or you cleared the cache?

    Can you create a new test page from Appointments > Settings > General > Display page. There is “Create an Appointment Page” tool, you should select “current week’s schedule” option and click create page button. Is that new page shows any difference?

    Cheers,
    Oguz

    Hi,

    I don’t use any cache plugin. When I changed the database entries it stopped working so I think it loads in the real time.

    I have created an appointment page, it is still from 10am 🙁
    https://trychologia-slask.pl/make-an-appointment/

    Cheers,
    Pauron

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hey @pauron,

    Hope you’re well.

    Could you contact us directly with this issue so we can investigate it further, you can use our contact form so we can see what can we do for you:
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Important: Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me.

    Subject: “Attn: Oguz”
    – Link to your WordPress site
    – Link back to this thread for reference
    – Any other relevant urls

    Cheers,
    Oguz

    Done.
    Look forward to hearing from you.

    Hi @pauron !

    Are you familiar with editing code either through FTP or via your servers Admin Panel ( cPanel/Pleks ) to see if we can make this work for you?

    If yes, make sure to keep a backup first ( preferably of your whole website just to be sure ). Although this code is for retrieving and showing the appointments, let’s be on the safe side before making any changes no matter how small.

    Could you please edit the file

    /wp-content/plugins/appointments/includes/helpers.php

    and on Line 692 you’ll see

    $slots = appointments_get_weekly_schedule_slots( $date, $args['service_id'], $args['worker_id'], $args['location_id'] );

    Replace that with:

    $worker_id = $appointments->get_worker_id();
    $slots = appointments_get_weekly_schedule_slots( $date, $args['service_id'], $worker_id, $args['location_id'] );

    Save the file and refresh your page to see if it worked.

    Keep me informed!

    Regards,
    Konstantinos

    Fantastic! It’s working!

    Thank you for such a professional support.

    Best regards,
    Pauron

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Changing working hours doesn’t affect on schedule table’ is closed to new replies.