Support » Themes and Templates » Changing width of k2 theme?

  • Resolved EDG


    I’m using the k2 theme on wordpress at and I like it, but I think it’s a bit too thin on the screen. I’ve got it set to two-column and like it that way, so I want to change it so that it takes up at least the same amount of room as the three-column version (but still be two columns).

    I had a look in the css file for it in Appearance>Editor, and I found some code there that says:

    .columns-two #page {
    	width: 780px;

    I tried changing that to 950px but while it widened the page, the columns didn’t widen too (there was lots of blank space). When I set it back to 780px, the whole layout got really messed up for some reason (I’d made no other changes) and I had to copy the original css file from the theme over the edited one again (via FTP) to fix it.

    I’m not all that familiar with css, but can anyone tell me what I have to do and/or edit to make this work? I really just want it to be 950 pixels wide, with the right sidebar staying the same width as it does now, but the main text window being wider and filling up the rest of the space.


Viewing 5 replies - 1 through 5 (of 5 total)
  • I figured it out. I’m not sure what happened first time when it went all screwy, but the solution is to change the code I showed in the snippet above, and then also change the width in this part of the code beneath it:

    #primary {
       position: relative;
       float: left;
       width: 500px;
       padding: 10px;

    The width entry in this code snippet should be adjusted to a value of (500+ (new width -780) ). So if the new width value (set in the first code snippet) for the full blog is 1000px, the new width for the main window is 500+(1000-780) = 500 + 220 = 720px.

    If you have a custom header image then that needs to be altered too, but the default is to set it at 780×200 and if you need a larger one (e.g. 1000×200) then it doesn’t display properly. I couldn’t figure out how to rectify that, but I did some clever tweaking of background colours and alignment with the 780×200 image and it works now.

    Hopefully that’s of use to somebody!


    I now would like to use a wider image (980×200) as my custom header, but it won’t let me use that because when you try to upload a larger image on the custom header page, it forces you to clip the image down to 780×200.

    Does anyone know how to disable or get around this so I can use my 980×200 image?

    Thanks, it helped me a lot! I hope I won’t have the same problem with the the custom header image…

    Hi EDG, did you find a solution to adjusting the width of the header? If so, please share!

    If you go to your site’s FTP you can just replace the file.
    the file will be in uploads / (the year) / cropped-(the name of your file)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Changing width of k2 theme?’ is closed to new replies.