Support » Plugin: Redirection » Changing the Query Parameters options for an existing link doesn’t save

  • Resolved Dave Redfern

    (@daveredfern)


    Hi there,

    First off, thanks for your hard work on this plugins. It’s been ridiculously valuable.

    After creating a link, if I try to edit the Query Parameters option, it doesn’t save the change. It always defaults back to “Exact match all parameters in any order”, despite selecting “Ignore & pass parameters to the target” before clicking save.

    Could you help?

    Thanks,

    Dave.

    • This topic was modified 1 month, 2 weeks ago by  Dave Redfern.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author John Godley

    (@johnny5)

    What are your default settings for query parameters on the options page?

    Hi John,

    The default setting is “Ignore & pass parameters to the target”.

    Thanks,

    Dave.

    Hi John,

    Just a follow-up (although I suspect you’ve already discovered the issue), if I change the default option to “Exact match all parameters in any order”, it saves the setting correctly.

    Thanks,

    Dave.

    Hi John,

    Sorry for the third response in a row.

    I’ve also discovered if the query parameter ends with a – (often MailChimp does this), the redirect breaks.

    Thanks,

    Dave.

    Plugin Author John Godley

    (@johnny5)

    I’m unable to reproduce either of those problems.

    Can you give an example of a URL with a ‘-‘ in that doesn’t work? Also can you show the settings for that redirect.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.