Support » Fixing WordPress » Changing the Blog address (URI) causes problem

Viewing 5 replies - 1 through 5 (of 5 total)
  • You can try to edit your .htaccess

    Did you change “siteurl” and “home” in table wp_options in your database? You should be able to use phpMyAdmin to do this.

    Hi,

    Also refer this article:

    http://codex.wordpress.org/Changing_The_Site_URL

    Thanks,

    Shane G.

    AlternativePhotography

    (@alternativephotography)

    Hi all, thank you so much for all your suggestions, tried them all, but no luck…

    @scofield

    My .htaccess file looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wp/index.php [L]
    </IfModule>
    
    # END WordPress

    I changed it to:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    But that did not work, probably did not change it right?

    @colombine
    I installed through Bluehost, I really have no idea how to change database stuff… a pointer, please?

    @shane G.
    Read the article, and tried the first thing: editing the wp-config.php by adding:

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    It made my admin panel disappear…. a little scary i think! I reverted and now it’s back. Phew!

    See this article for changing the entries in your database: http://www.tamba2.org.uk/wordpress/site-url/

    Once you get in there, go to Settings > Permalinks, and double-check that your permalinks are set as they should be, if not, then set them as they should be, either way, click to save the settings. If you still have problems with some of your pages, change your permalink settings and change them back again then save again. Also try deactivating plugins.

    If, after that, you still have problems, post a link to your site here so someone can take a look at it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Changing the Blog address (URI) causes problem’ is closed to new replies.