WordPress.org

Support

Support » Installation » [Resolved] Changing Permalinks gives 404 error

[Resolved] Changing Permalinks gives 404 error

  • Hi, Anytime i change the permalink structure to anything other than the default setting i get a 404 error (using my system as a local server). I tried setting up a fresh installation of wordpress and changing the permalinks before any pages were created and it still gives me the 404 error. Please i would really appreciate help in getting this sorted out. Because one of the plugins i need to use requires that the permalink structure be something other than the default setting.

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you are using a local install you must make sure that the Apache Rewrite module is enabled. Sometimes its installed locally with that module commented out in the Apache httpd.conf file

    The line in my file is
    LoadModule rewrite_module modules/mod_rewrite.so

    If there is a hash mark # at the front of that line, remove it and save the file. Or you can change it through your LAMP software’s control panel.

    Ive removed the hash mark # from the “LoadModule rewrite_module modules/mod_rewrite.so” in the httpd.conf file but im still getting the same error.
    Will try reinstalling afresh and see what happens

    I’m sorry, I forgot to add that you have to shut down and restart your LAMP installation after making that change.

    Hey thanks alot!!! it works!!! Really Grateful for your help

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Changing Permalinks gives 404 error’ is closed to new replies.
Skip to toolbar