WordPress.org

Support

Support » How-To and Troubleshooting » Changing Permalinks

Changing Permalinks

  • I’m starting on my site at http://harmonywheeler.com/index/ and would like to make it as professional and non-blog as possible. I’d like to either redirect the permalink for the few posts I put on the home page so that they reroute to one of my other pages, or disable them all together. Is this at all possible? I don’t want to use a page layout for the home page because you can only have one post with that and it also messes up the template and makes the banner at the top disappear.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I checked out your site but I can’t really determine the issue you are having unless you made changes after your post. If you are still looking for assistance, would you be able to provide a little bit more info?

    The only post I currently see is the one that links to your biography. Are you saying you want to redirect that to an actual page instead of a post?

    There are currently two posts and yes that is what I’m saying. I’d like to link the post title to an actual page or deactivate the link for the title so there’s no way to go to a single post page.

    If you are familiar with HTML you can go into your theme and modify it so that there isn’t a link on your home page. If you decide to do that make sure to create a child theme first – http://codex.wordpress.org/Child_Themes

    I’d be slightly wary of the theme you are using though as it has spam links down in the footer. There was some recent Google news that these types of links are not favored and could potentially hurt your rankings in search engines. Although if you aren’t worried about Google then you have nothing to worry about other than the fact that the links look a little unprofessional.

    I gather that it has something to do with

    `<div class=”title”>
    <h2><a href=”<?php the_permalink() ?>” rel=”bookmark” title=”Permanent Link to <?php the_title(); ?>”><?php the_title(); ?></a></h2>
    <div class=”titlemeta”>`

    but what do I change it to? I’m not super familiar with HTML.

    All you need to do is use static page in Settings>>>>Reading and select the static page as your home page from drop down in front page and leave post page as select.

    Now you will not have any post pages in your menu

    Change it to show

    <h2><?php the_title(); ?></h2>

    Thank you JarretC – you just made my day with the easy solution!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Changing Permalinks’ is closed to new replies.
Skip to toolbar