Support » Themes and Templates » Changing Menu behavior – disable top level page nav

  • Resolved cocococo


    Hi there

    I have child menus. However, the top level (parent) menu item ALSO calls a page, and I wanted a passive click-only item to drop the other page choices down – people are reporting they missed the first item (top level parent page). I’m using a child version of twenty eleven

    On THAT note, some of the fixes suggested in the forum work only on the original parent style.css. When the code is put into the child style, it doesn’t work. When the same code change is made in the parent, it works.

    Is there a reason for that?


Viewing 4 replies - 1 through 4 (of 4 total)
  • If I understand you correctly you want a top level menu label (Foo) that drops down a sub menu of child pages when clicked, but you don’t want users taken to a page called Foo when Foo is clicked. Is that right?

    If so, under Menus > Custom Links create a link with a url of # and a Label of Foo and add that to the menu. Add your child pages underneath Foo.

    You will get the dropdown effect when hovering unless you override the css that provides that.

    Thanks garydarling

    I’ve done that. It’ll seem REALLY obvious, but how do I connect the sub-menus? the Menu/submenu relationships are established in the page definitions – and the new menu (foo) doesn’t have a page.

    So, how do I connect the new top level (Foo) to the other menu items I’d like to ‘drop down’ (which are existing pages)


    In Appearance > Menus is where you establish the menu / submenu relationship. From the Menus Codex:

    After items have been added to a menu, drag and drop to put them in the order you want. You can also click each item to reveal additional configuration options. You can also drag a menu item a little to the right to make it a submenu, to create menus with hierarchy. You’ll see when the position of the drop target shifts over to portray the nested placement. When you have finished building your custom menu, make sure you click the Save Menu button.

    Thank you – so simple. Your help has been much appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Changing Menu behavior – disable top level page nav’ is closed to new replies.