WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » [Resolved] Changing locale from en_US to en_AU

[Resolved] Changing locale from en_US to en_AU

  • The site is http://www.trainsem.com/

    I have edited wp-config.php and uploaded the en_AU.mo file after renaming it from en_GB.mo.

    The top part of the page code looks like it has picked up the locale as Australia:

    <!DOCTYPE html>
    <!–[if IE 7]>
    <html class=”ie ie7″ lang=”en-AU” prefix=”og: http://ogp.me/ns#“>
    <![endif]–>
    <!–[if IE 8]>
    <html class=”ie ie8″ lang=”en-AU” prefix=”og: http://ogp.me/ns#“>
    <![endif]–>
    <!–[if !(IE 7) | !(IE 8) ]><!–>
    <html lang=”en-AU” prefix=”og: http://ogp.me/ns#“>

    However, the Yoast SEO plugin v1.4.13 part of the code hasn’t changed:

    <meta property=’og:locale’ content=’en_US’/>

    What is causing this and how to fix it?

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I just checked in the code – the reason for this is that Facebook only supports a limited list of locales and en_AU is not supported. Which is why it the og:locale defaults back to en_US.

    If Facebook has started to support en_AU, it could be added to the valid locales list.

    Hope this helps.

    Smile,
    Juliette

    Oh, that’s sad. Thanks for checking. I hope in the future it won’t affect currency matters, so I can live with en_US.

    I have the same problem my site is http://www.teksyte.com I am using yoast Version 1.4.15 but I can’t find where to tweak this en_US for en_GB

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Changing locale from en_US to en_AU’ is closed to new replies.
Skip to toolbar