Support » Fixing WordPress » Changing links after migrating from WP.com – broken image links

  • Hello,

    I just finished migrating my site from WordPress.com to WordPress.org. It seemed that all my pages, posts, and image files made it over okay, but I was trying to update the internal links and I guess I might’ve messed up the image links. (Should I have even been trying to change those?)

    This post in particular seems to have gotten half of its photos broken/lost, despite the fact that all the photos show when I go in to edit the post. There may be other posts affected as well, I just haven’t looked for them yet.

    Any suggestions for how to fix the image URLs?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • You can use “Velvet Blues Update URLs” plugin, to change all old website links with new ones.

    There’s a short tutorial to show you how to do it available at: https://www.youtube.com/watch?v=pzI9quk29_s

    Thanks Mateus. I tried that before and it didn’t change very many of the links even though I tried entering the “old links” URL several ways.

    i would just install notepad++ and download database backup and run search and replace on all links after migration.

    Also sometimes happens when images have funny characters in names, after migration they get scrambled, so only solution would be to go thru files backup and check are all the images existent and their names.

    I see you are using Jetpack to speed up your images, maybe you can check that and also in debug console your site have 5 errors and 6 warnings.

    • This reply was modified 1 year, 9 months ago by Slllobodan.
    • This reply was modified 1 year, 9 months ago by Slllobodan.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Changing links after migrating from WP.com – broken image links’ is closed to new replies.