Support » Theme: Hueman » changing language file

  • Resolved aviator737


    Hey, thanks for a great theme.

    I’ve been trying to create a swedish version of the theme but for some reason it’s not working. I’ve edited the languages/en_US with POEDIT, initially I created new ones sv_SE and followed the usual steps but that didn’t work either.. I tried to change for e.g. “Follow;” to “Follow us” to maintain “english” but that didn’t work either so basically any inputs I do doesn’t work.

    Any ideas? I don’t want to change the core files, I want to get this language issue working, thanks again. Grymt jobbat 🙂

    Happy new year!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Gott nytt år 🙂 Tack!

    I would recommend reading this quickguide to see if there is anything you might’ve missed.

    – Is the WordPress installation in swedish?
    – If you are using a child theme (download sample child theme here) to load the lang files, you need to copy over the whole alx_load function to the child theme’s functions.php and change this line in it:

    // Load theme languages
    load_theme_textdomain( 'hueman', get_template_directory().'/languages' );


    // Load theme languages
    load_theme_textdomain( 'hueman', get_stylesheet_directory().'/languages' );

    In order for it to load from the child theme’s languages folder instead.

    Putting a sv_SE.po file in that folder, if correctly edited and saved and on a Swedish WP install, should work.

    If I onderstand correctly, did you changed the default theme language files? If so, I think that somewhere in the header of that .po file it says that the language is English (I have made an Dutch translation and I have to say my translation is Dutch). So maybe you have to change the language of the file in Swedish (in POEdit that is, menu option Catalogue – Preferences), save it and try again. I believe that your browser is sending it’s language preferences to the webserver which than responds with the correct language, if it exists (see ).

    Of course it is better to use a child theme and make the changes over there, as Axel has stated in different answers here in the support forum (you have to put the function alx_load in your functions.php in the child theme and change get_template_directory() into get_stylesheet_directory() in the line for the language file, just changed that myself and it is working for me).

    I checked it, everything seems ok but still nothing.

    Yes wordpress is in swedish and i’m using your child theme with the alx_load function, did change the template to sylesheet and still nothing, I’ve tried several methods but can’t get it to work.

    I don’t think that it is neccessary to have WordPress in Swedish. That is only the case if the Hueman theme options itself needs to be translated. In that case, WordPress uses the language of the WordPress installation deinde in/with wp-config.php.

    But in this case, only your website has to be translated. If I visit my own website from my iPad, there is no WordPress installation at all but it still translates to Dutch.

    Have you checked the language of the .po file you are using (it is stated in the .po file itself).

    Ok finally managed to get it solved, thanks again Alex =) Cheers

    Sweet, what was the issue?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘changing language file’ is closed to new replies.