WordPress.org

Forums

changing index page? (11 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    I finally got everything together and up and running, except that its under my "wordpress" directory. How do I get at least the index file, and everything it needs to point to under my main directory. (Basically, how do I have my site address stay as http://www.haveyoumettony.com instead of haveyoumettony.com/wordpress?)
    Thanks!

  2. Kafkaesqui

    Posted 10 years ago #

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    Thanks! I knew it had to be somewhere easy, but didn't know what keywords to search for.
    The only question/problem I have is steps 4 & 5. I've never done anything with databases before, so I'm not sure what information to put into the wp-config-sample.php file (though I did find it and see where I'm supposed to put it). The username/password seem simple enough, but right now it says "wordpress" as the database name, does that stay the same? Or change to something else I've named it? It seems like I named the database wordpress, so it should stay the same, right?
    As for step 5, I'm guessing since I'm not even sure what mod_rewrite does, I probably don't have to mess with that, right?
    Thanks again for the quick help!

  4. moshu
    Member
    Posted 10 years ago #

    For db name put whatever you named your own database. It doesn't have to be "wordpress" - that's just an example (mine always have funny names :). Step 5 will come later, but it is not mandatory. Don't worry about it now!

  5. Kafkaesqui

    Posted 10 years ago #

    4. As long as the only thing that's changed is the location of index.php (and any related files), I'm not sure I see a need to redo anything in your wp-config.php.
    5. This would relate to any changes you may have made for permalinks (Options > Permalinks). If you've made none, then you're all set here.

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    okay, I think I'm close... but still nothing.
    I've got a copy of my index.php in both my main directory and my wordpress directory, I *think* I've got the information right in the wp-config.php file, and have that copied in both the main and wordpress directory (where does that have to go?) I moved my old "index.shtml" file out of the main directory, since that kept popping up, but now I get a totally blank page when I enter either my domain, or the domain with the "index.php" extension.
    Any ideas? Or should I start tugging my hair out now?

  7. moshu
    Member
    Posted 10 years ago #

    OK, you need only ONE index.php for WP. If you want it in your main (root) directory - i.e. "different address" - then the link provided by Kafka tells you what to do. And you do NOT need to have another wp-config file in the main directory. Leave everything where they should be, you move only the index!

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    I've got one index.php now, and the only thing labeled "index" (with ANY extension) in my root directory is "index.php". But still it comes up as a blank page.
    Now I think something else is screwy, as I went to double check the settings on my Options page, and I get an error message trying to get to my wp-admin.
    Do you guys see anything when you call up http://www.haveyoumettony.com?

  9. moshu
    Member
    Posted 10 years ago #

    Did you delete the second config file from your root (main) directory?
    What kind of index file are you using? because what is there it isn't the WP index file...

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    there are now no config files in my root directory, just in the wordpress directory.
    and the index file in the root directory is the index.php file that worked perfectly when it was in the wordpress directory.

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    got it!!! (as far as I can tell, at least)
    I just ended up replacing the wp-config.php file I had in there (that I thought I needed to change) with the original wp-config.php that came with the original install. I can get into my admin panel, and my site comes up on the main domain.
    Moshu and Kafka... thanks SOOOOO much for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.