WordPress.org

Forums

Changing .htaccess does not work - posts can't be read afterwards (7 posts)

  1. Marius-
    Member
    Posted 5 years ago #

    Alright I've installed WordPress 2.8 through Fantastico in Cpanel. Which contained no .htaccess file, so I had to create it myself.

    I've tried putting it in several folders. Like the root folder, and then the theme folder, where the indexfile I now use is.

    After doing this, the site sometimes misloads. But most importantly, posts can't be opened. Even though I've followed the instructions.

    Why does WordPress have to make this so hard to do? I just want prettier permalinks. WordPress is about easyness, this whole .htaccess crap annoys me. Can someone help me out?

  2. Rhand
    Member
    Posted 5 years ago #

    Did you activate permalinks in the WordPress Dashboard. There it even creates the .htaccess for you after you have chosen what permalink structure you want.

  3. zartgesotten
    Member
    Posted 5 years ago #

    Marius,
    Do you have mod-rewrite enabled on your server?
    That might be the problem.

  4. Marius-
    Member
    Posted 5 years ago #

    What, where do you activate the permalinks?
    Cause it said that it didnt have access to my .htaccess.

    I dont know if I have mod-rewrite. I could check, do you know how to check that with Cpanel?

  5. zartgesotten
    Member
    Posted 5 years ago #

    Put chmod rights 777 on your whole WordPress - foldeR (just the folder, not all files and subfolders), then go to dashboard and into the settings. There should be a menu item named "permalinks". There you can define what your nice links will look like and wordpress will generate the file for you.

    If you get errors after that, you probably don't have mod_rewrite. You can check that by uploading a .php file to your server (anywhere) with

    <?php phpinfo(); ?>

    in it and calling it in your browser. Then look out for mod_rewrite and see if it's on.

    If it's your server, you can turn it on yourself, if you're with a provider it depends...

    Let us know what happened.
    Good luck
    anja

  6. Marius-
    Member
    Posted 5 years ago #

    I don't understand what you mean by "Put chmod rights 777 on your whole WordPress"

  7. Rhand
    Member
    Posted 5 years ago #

    Use a FTP program like Filezilla for it. Right click the folder where WordPress is in and change the file permissions to 777. Meaning read write and execute for all on that folder. CHMOD means change mode under unix and linux. CHMOD 777 from the shell command line gives a file or folder Read Write and Execute for all. Right clicking and adding 777 in Filezilla will do the trick as well. Always be careful about using CMHOD 777 though as it could cause a security risk in certain cases.

Topic Closed

This topic has been closed to new replies.

About this Topic