Support » Installing WordPress » Changing Host issue

  • I am changing hosts and have uploaded all my files.

    The first page is perfect but as soon as I try to select another page it says the page is not available.

    It allows me to log-in to the admin and everything looks perfect there also.

    I even tried editing each page and then saving it but still wont work.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Reinstalled the database and now the issue it when I click on a new page it still points at my old domain name.

    I don’t see anything in the config file that actually points towards any specific domain.

    Have to made the changes in the database? There are 2 entries in table wp_options table. One is siteurl and the other is home.

    Thank you.

    That helps but now I am back to the same original problem.

    It says the page doesn’t exist. The front page is perfect but as soon as I try to go to another page it says it doesn’t exist.

    I can get into the admin and edit the page but still no luck.

    Hello have a look at this tutorial I found. See if you have performed the same steps as this tutorial….

    http://blog.triphp.com/how-to/how-to-move-wordpress-to-a-new-server-or-host.html

    Kind regards

    Go into the backend and re-save your permalink settings. That usually fixes it.

    Yes I followed the instructions about and have completed each step.

    I re-saved the permalink and still no luck.

    If it helps here is the link….

    Is the following path http://www.elio.me/theJourney/ how you had it on the other server? What version of wordpress are you running? It looks to me like you are running a subdomain path “theJourney”. I am almost certain your file structure is pointing to the wrong path and that is why you get the page not found even though it is there. Have you had a look at you .htaccess file? This is just another theory I am adding.

    The original path was….

    http://www.eliocamacho.com/theJourney

    I checked the .htaccess file and this is it.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /theJourney/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /theJourney/index.php [L]
    </IfModule>

    # END WordPress

    BTW….I upgraded to the latest before transferring it.

    I have another idea, why don’t you install a new installation of wordpress to another sub directory i.e http://www.eliocamacho.com/test. Have a look at the settings both .htaccess and the link structure from the admin side and see what is the difference.

    Because of your situation this might help you troubleshoot your problem.

    This is just a suggestion

    Kind regards

    That seems like a good idea.

    Will keep you posted.

    Hi it seems that you have fixed the problem. Can you let me know what was the problem 🙂

    Kind regards

    hi…
    There is a alternate solution export your data base and open this file in to any editor and replace all old url(like http://localhost/wordpress) to new url .
    and go to ur dashboard and reactivate your theme and perma link.
    In case you not able to fix the bug please reinstall a fresh wordpress and replace the wp-content folder with old one and also the old data base .

    I followed instructions above in the upload_path.

    I had the correct path just to much info.

    All it need was “wp-content/upload”

    Thank you without your suggestion I would not have solved it.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Changing Host issue’ is closed to new replies.