WordPress.org

Support

Support » Themes and Templates » Changing global font to Ariel

Changing global font to Ariel

Viewing 8 replies - 1 through 8 (of 8 total)
  • Erm! Spell it right in your style rule 🙂 You have:

    body {
      font-family: "Ariel";
      font-size: 1em;
      line-height: 1.2em;
    }

    It’s ‘Arial’ unless I’m very much mistaken.

    Also you should always end your font list with a generic font or your browser will revert to it’s default font (probably a serif one) if Arial is not installed on the machine. So your font list should be, at the very least:

    Arial, sans-serif;

    Also, if you’re making changes to a theme and don’t have complete control over the code, the only recommended way of doing it is via a child theme.

    HTH

    PAE

    Hi Peredur,

    Thanks for your reply.
    Don’t know which file to edit your suggested code into.

    I’ve tried something with the style.css file, but that did not work out.

    hope you can help a bit more.

    thx
    Chris

    What did you put in the style sheet, and where in the style sheet did you put it?

    Cheers

    PAE

    Hi Peredur,

    I’ve added your bit of code to the style.css file of the template I use.
    I’ve taken it out again, ’cause it didn’t do anything (like I said, I’m clueless about coding).
    Below is a snippet of my style.css file:

    /************************************************
    * ^1 Global Settings
    ************************************************/
    body {
    font-family: “Adobe Garamond”,Georgia,”Times New Roman”, serif;

    YOUR SUGGESTED CODE HERE

    font-size: 1.0em;
    line-height: 1.2em;
    z-index: -1;
    margin: 0;
    padding: 0;
    }

    thx
    Chris

    Well, if you really put in the text “YOUR SUGGESTED CODE HERE”, then that would wreck it.

    What I am suggesting is that you put your font list in a new rule for the body, probably at the end of this style sheet.

    It would be better in a Child Theme, since child themes are the only recommended way of modifying a theme, but still…

    Now I don’t know what you want the font list to be, but if you want Arial fonts, at a minimum you need something like:

    body {
      font-family: Arial, sans-serif;
    }

    When you’ve done that, please leave it there even if it doesn’t seem to work. If you don’t, I can’t see what’s going on.

    Cheers

    PAE

    Moderator Michael

    @alchymyth

    Forum Moderator

    I’ve taken it out again, ’cause it didn’t do anything

    don’t – just leave the suggested changes in the code until someone had the change to check back for troubleshooting.

    @peredur‘s suggestion should work, or this edit:

    /************************************************
    *	^1 Global Settings
    ************************************************/
    body {
     font-family: arial,sans-serif;

    you might need to clear the browser cache to see the changes to your style.css – ‘CTRL F5’ or ‘reload’

    basic formatting help is not within the scope of this WordPress forum – please ask at a general webmaster forum.

    Ok, got it working now.
    My font “turned” Ariel (which is what I wanted).

    Now… How can I change the font size?
    It currently reads: font-size: 1.0em

    I’d like it to be smaller.

    thx
    Chris

    Bigger? Smaller?

    Just change the font-size value, preferably in the same rule as you used before:

    body {
      font-family: arial, sans-serif;
      font-size: /* whatever font size you want */
    }

    Or you can use the shorthand font property:

    body {
      font: 14px/1.25 arial, sans-serif;
    }

    Or whatever values float your boat.

    For details on the font property see a site like w3schools.

    Cheers

    PAE

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Changing global font to Ariel’ is closed to new replies.