Support » Fixing WordPress » Changing feed url

  • I see that the URL of the feeds is /feed, but when google crawls my site it receives a 403 error (forbidden).
    I’d like the feed URL to be the full URL (/feed/index.xml), how can I do this?

    Ps: I have a static site made with the plugin Simply static, but the feed dirs exist and contain the index.xml files

    • This topic was modified 2 years, 1 month ago by sherlock16. Reason: wrong typing
    • This topic was modified 2 years, 1 month ago by sherlock16. Reason: partial typing
    • This topic was modified 2 years, 1 month ago by sherlock16.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    I get an error on http://www.justthink.it/feed/

    Do you have a directory called “feed” that might be getting in the way? Maybe a security plugin or line in .htaccess?

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    As I added, I use the Simply Static plugin and the site is a static WordPress site, so there are no plugins active when you visit the site.
    As I wrote after you visited my site, I have a feed dir and if you try http://www.justthink.it/feed/index.xml it works. So I thought adding index.xml to the path could solve my issue. I have no .htaccess file.

    Ps: I think you get an error because when requesting /feed you ask for the directory listing and this is disabled on the site. I cannot change this

    • This reply was modified 2 years, 1 month ago by sherlock16.
    • This reply was modified 2 years, 1 month ago by sherlock16.
    • This reply was modified 2 years, 1 month ago by sherlock16. Reason: wrong typing
    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    I recommend asking at https://wordpress.org/support/plugin/simply-static?#new-post so the plugin’s developers and support community can help you with this.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Changing feed url’ is closed to new replies.