Support » Plugin: FA Lite - WP responsive slider plugin » Changing Feature Images breaks slider

  • I just moved a site from a test server to a live server.

    First, I had to deactivate and then reactivate the plugin to get it working on the live server.
    That was no biggie.

    My issue now is that if I update the featured image of any page included in a slider, the slider breaks. Here’s the error (with my site URL redacted:

    Warning: Invalid argument supplied for foreach() in /home/mysite/public_html/wp-content/plugins/featured-articles-lite/includes/functions.php on line 687

    Fatal error: Call to undefined method WP_Error::set_quality() in /home/mysite/public_html/wp-content/plugins/featured-articles-lite/includes/functions.php on line 713

    I have already updated to the latest version of the plugin and it did not resolve the issue.

    Any advise?

    https://wordpress.org/plugins/featured-articles-lite/

Viewing 1 replies (of 1 total)
  • Plugin Author CodeFlavors

    (@codeflavors)

    Hi,

    Seems like when trying to get the attachment image meta data, the plugin gets a WP_Error returned to it. Can’t say why, it should get an array or “false”. Most likely, another plugin or your WP theme is short-circuiting WP’s get_metadata() and for some reason returns the error.

    Would it be possible to grant me temporary access so I can take a look and see what’s going on? If yes, please contact me at codeflavors[at]codeflavors[dot]com. Please let me know, thank you.

Viewing 1 replies (of 1 total)
  • The topic ‘Changing Feature Images breaks slider’ is closed to new replies.