Support » Plugin: Search & Replace » Changing domain via ‘Search & Replace’ tab throws an error

  • Resolved Robert Simpson

    (@rsimpson)


    Hi folks,

    I’m in the process of moving my media library over to a subdomain and when I try to mass-update all of the references in my posts, the plugin throws this error:

    Your search contains your current site url. Replacing your site url will most likely cause your site to break. If you want to change the URL (and you know what you doing), please use the export function and make sure you backup your database before reimporting the changed SQL.

    I’ve changed the primary domain in this fashion countless times in this fashion (moving from dev URL to production URL) but I’ve never been hit with this error before, and it’s probably going to serve as a major hinderance when I try to do the same thing in the future.

    It would be useful if instead of throwing an error it was a warning with the option to proceed as normal, otherwise this plugin will basically have lost most of its usefulness to devs who use it the way I do.

    Otherwise, keep up the good work!

    Cheers,
    Robert

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Rene Reimann

    (@derpixler)

    Well thanks Robert for your Feedback. We will evaluate this.

    Hi @rsimpson, this has actually been fixed now and will be in the next release. I apologize for the delay in responding and for the issue you encountered.

    Hi Rene & Brandon,

    I am using your plugin to update my sites from http: to https: after installing the Lets Encrypt SSL certificate. The first site I updated was fine, but on the next two I’ve tried to use it on then I got the same message as Robert above?

    For me I wondered if this is because the first domain is the Primary Domain and the others are Add On domains? Could this be it, or should your next release fix this anyway. And if it should, when is the next release due please?

    If it IS because it’s different on Add On domains, then can you offer another solution? For a learning but basically not too techie person!!

    Cheers,

    Alan

    Hi Brandon & Rene,

    Can you tell us when the next version, containing the fixes for this, will be released?

    It’s proving to be a real problem for us too.

    Thanks.

    Same problem here. I was just about to launch a new website and found this issue. I’ve solved it downloading the last code on the Github repo.

    When are you guys planning to release next version?

    I have similar error too…but…you may change part of your domain

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Changing domain via ‘Search & Replace’ tab throws an error’ is closed to new replies.