Support » Plugin: Pods - Custom Content Types and Fields » Changes won't save

  • Resolved WordPMTL


    Strange thing has started occurring out of the blue. When I make a change to the pod (i.e. add a field) and click save, it spins and then confirms that the changes were made. But the new field isn’t created. Same thing if I delete or edit fields.

    Also, if I edit any of my advanced content types (i.e. change someone’s name in one of the fields) and save the ACT, it doesn’t save.

    So I can’t edit the Pods themselves or any of the ACTs created from those pods.

    I also tried using the Pods User Role Editor and changes I made there didn’t actually save when I saved.

    I tried with regular wordpress pages and posts, and they save fine.

    I have tried clearing the Pod Cache but it didn’t help.

    Here is my debug output:

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Josh Pollock


    Your debug info shows that the save session path is not writable. This is almost always a server setup issue that needs to be resolved by your server admin or hosting provider. To confirm that it is not a Pods issue, you can deactivate Pods and then try the following in the PHP console or in your header.php:

    var_dump( session_save_path()  );
    if ( is_writable(session_save_path() ) echo 'Writable!';

    If this returns a file directory and Writable! with Pods deactivated then please let us know as that would indicate an issue with Pods. If it returns false then something needs to be corrected with your server.

    Thanks Josh, you’re a star. I updated my php5.ini file to have session.save_handler point to a temp directory I created in my root with 777 permissions and now it works.

    Not sure how that disappeared in the first place. But it wasn’t a Pods issue after all.

    Thanks again!

    Plugin Contributor Josh Pollock


    I’m glad to help and to see that you got this resolved. While it’s not a Pods issue, Pods ends up being the plugin that shows people the issue, and we have had a handful of reports of this since the 3.9 update.

    Hi Josh,

    It seems that the issue is continuing to occur. When I make a change to a pod’s field, for example, it will sometimes save the change, sometimes not. In all cases it tells me that my changes were saved, but they aren’t always.

    Same thing if I edit a specific pod item.

    Also, if I delete a few pod items through bulk delete, it will always say they were successfully deleted. But sometimes they are actually still there and I need to do it again.

    Here is my log. Thanks for any thoughts you may have:

    Plugin Contributor Josh Pollock


    I’m sorry to see that this is happening again. Have you tried disabling all other plugins and see if you can reproduce the issue?

    Also, what type of hosting are you using? Given what happened before, I wouldn’t rule out a server issue.

    Hi Josh, thanks again for the quick reply.

    It is hard to make the error happen. It used to happen 50% of the time I made any change, but now it’s only about 5-10% of the time.

    I wouldn’t rule out hosting either. I am with GoDaddy and they aren’t the greatest.

    I will try disabling plugins and let you know if I get any closer to determining the culprit.

    On a side-note, have you had positive experience with certain hosting providers, and if so do you mind sharing with me the company name and package? I have done a lot of research online as I am thinking about switching, but so many opinions out there that a single recommendation from a competent person who uses WordPress a lot might be better!

    Plugin Contributor Josh Pollock


    Please let me know about the no other plugins test.

    Getting a way from GoDaddy, or any host that runs PHP 5.2 is a very good idea, in my personal opinion. runs on WPEngine and my personal sites run on SiteGround. I would recommend either strongly. Both hosts can be expensive, but you get what you pay for. I don’t know what your specific needs are, but if you are going to be using Pods with a lot of custom fields and/ or a large database, it is really worth getting good quality hosting.

    Thanks so much for sharing. I will look into those. Not sure if managed hosting (WPEngine) is what I need, since that can restrict the allowed plugins, but perhaps shared hosting with SiteGround would be an upgrade from GoDaddy. Thanks again Josh.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Changes won't save’ is closed to new replies.