WordPress.org

Forums

[resolved] changes to style.css nonexistent (6 posts)

  1. johnyc213
    Member
    Posted 1 year ago #

    Hello out there!

    So I've made a very small change to style.css on ftp server to a theme being used for homepage. I used firebug to see where the change needed to be made, and everything looks great there. So I go to the file system, pull off style.css, make the edit, changed file permissions (644->777), and overwrite the old file. Then I go to the website (commair.biz) and the change is not apparent. So I go to wordpress and check out style.css through the editor, and nothing is different at all. Same code as before I started. So I went back to the file system (using FileZilla) and double checked everything. I AM editing the right theme's style.css. I DID change file persmissions, and the file IS overwritten correctly in the file system.

    Can anyone tell me why wordpress is refusing to recognize the change?

    I would copy and paste it right in to wordpress editor but it has that message about needing to change the file permissions and checking out the codex. I know I'm editing the right style.css because the one I pulled off the file system is identical to the one wordpress editor shows me but wont allow me to change (frustrating) and identical to the one firebug pulls up and allows me to edit on the fly.

    Also I have cleared all my browser caches and even tried pulling up the page and wordpress editor on different machines so I'm quite sure this isn't a caching issue.

    Please help a wordpress n00b!

    If anyone wants to check out what im trying to do the website is commair.biz and the owners want the "A" "B" and "C" grey circles below the picture frame completely gone. I'm attempting to simply go into the styles.css and change their display: to "none". This works awesome in firebug but we all know getting firebug on the fly edits to work the way they should is not always a trivial task.

  2. Jesin A
    Member
    Posted 1 year ago #

    May I know what change you did to the code. Sometimes CSS priorities may override each other.

    Also it is best to place your own CSS either in the custom CSS box provided by the theme or by using a plugin like PC Custom CSS. Else the changes will be overwritten when you update the theme.

    I find that adding the following CSS code remove those circles

    ul.services li b {
      display: none;
    }

    You may try adding !important after display: none if iy doesn't work for you.

  3. johnyc213
    Member
    Posted 1 year ago #

    that is the exact change that i made! its not that the code is being overwritten or anything like that i dont think, its that wordpress isnt picking up the changes i made at all. Its almost like wordpress has a cached version of style.css that its using rather than the one on the file server that i made changes to..

    Again, the style.css code wordpress shows me in the editor DOES NOT show the change i made to style.css in the file system.. It makes me wonder if the person who wrote the page hid the style.css somewhere..

    On the file system its under httpdocs/wp-content/themes/theme1671, which i find somewhat odd because the name of the theme in style.css is literally "WordPress Theme Number" (entirely nonsensical).

    A piece of evidence leading me to this conclusion is that even when i change the file permissions of this style.css, wordpress editor still gives me that message at the bottom of the editor telling me i need to change the file permissions and read the codex more.. (real helpful)

    Im at a little bit of a loss here because its the style.css in this theme on the file system is identical to the style.css wordpress shows me in the editor, so im somewhat confident it is the right file. I just cant figure out why wordpress isnt picking up the changes im making to the file system..

    Just to make sure.. is there a simple checkbox setting somewhere that is evading me that allows this style.css to be changed? When surfing around the forums ive heard of a "use custom css" setting or something but honestly.. i cant even find it.

  4. johnyc213
    Member
    Posted 1 year ago #

    OH! GOT IT!! all i did was throw those couple lines of code in the custom css box at the bottom of theme options.. so simple! Still at a loss as to why my changes to the file system werent showing up but at least the job is done.

    Thanks for your reply jesin!

  5. WPyogi
    Forum Moderator
    Posted 1 year ago #

    EDIT - cross-posted with you - but please see the last part of my post about non-GPL themes - we don't support those here at all.

    Custom CSS is a theme option or plugin. There is no reason that you should not use the Appearance > Editor to modify files - EXCEPT that any changes will be lost when the theme theme is updated. So don't modify theme files period (via FTP or the dashboard) - use a child theme or add custom CSS.

    Try switching to twentytwelve theme and see if you have the same issue - to see if it's your theme or not.

    Along those lines, you are using a theme that is not released under the GPL licensing requirements of WP - I'd actually strongly suggest that you rethink that.

  6. Jesin A
    Member
    Posted 1 year ago #

    You're welcome Johny.

    When was the last time you edited style.css? The HTTP headers of that file shows 16th August as the last modified date.

    HTTP/1.1 200 OK
    Date: Fri, 06 Sep 2013 17:47:55 GMT
    Server: Apache/2.0.63 (CentOS)
    Last-Modified: Fri, 16 Aug 2013 17:20:28 GMT
    ETag: "4be4a24-e832-ce918f00"
    Accept-Ranges: bytes
    Content-Length: 59442
    X-Powered-By: PleskLin
    Content-Type: text/css
    X-Pad: avoid browser bug

Topic Closed

This topic has been closed to new replies.

About this Topic