Support » Theme: GeneratePress » Changes Not Showing/Disappearing

  • Resolved mus2018

    (@mus2018)


    I’ve been having a problem for a while now where sometimes changes I make on Elementor Pro don’t show up on my site. I’m using the free Generate Press and the Pro version of Elementor.

    I posted about my problem with the background color not changing properly here (a similar problem): https://wordpress.org/support/topic/trouble-with-changing-background-color/#post-10897732
    Leo helped me out but I’m not sure that all of my issues can be fixed with code.

    I added the ‘featured on…’ section as a side bar using the Elementor builder. The font should be Sacramento (like the ‘Recent Posts…’) and the background should be white. Instead, the font is some default and there’s no white background. It shows up as it should when I edit the template in Elementor.

    I pressed the ‘Purge SG Cache’ button and it fixed the problem, but when I left clicked away from the homepage and came back, the problem was back again.
    I’ve been in and out of the homepage repeatedly – sometimes the problem is fixed, other times it’s not. I’ve also tried ‘Elementor > Tools > Regenerate CSS Files – I think that worked once (just like purge SG cache’) but it hasn’t fixed the problem.

    I’ve also had this problem in the past few weeks when I try to change my default heading fonts in Elementor. It shows up fine in Elementor template editor, but the font I want doesn’t show up on my actual site when I leave the editing process. It changes to a generic default font instead on my actual site. The font I want to use isn’t available in WordPress’ Generate Press default options.

    Another problem I have is with my main section box changing position relative to the header. I had to apply different margin settings for my normal post template vs my homepage template to have them looking the same distance from the header, even though they should really look uniform with identical settings.

    I can’t even edit my default template for posts without featured images (see here https://makeupscholar.com/before-after-makeup/), because anytime I try to edit the main section box, the mouse hovers over and clicks on the ‘About Us’ button in the header (instead of the 3 blue dots) and forces me out of Elementor.

    This all happened before I updated to the new WordPress. I have now updated to the new WordPress and sadly the problem still remains.

    I don’t know if WordPress is overwriting my changes in Elementor? I’d be really grateful if someone could help me out, because this looks like it will be a recurring problem for me.

    If there’s code or something I can edit to help solve this problem, please let me know.
    https://wordpress.org/support/theme/generatepress/

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Theme Author Tom

    (@edge22)

    Hi there,

    These mainly sound like caching issues to me, although they shouldn’t persist after you clear your caches.

    Most of the problems seem to be Elementor editing related – have you posted in their support forums as well?

    Hi Tom,

    Thanks for the quick reply! I stepped away from my site for an hour and the changes to the side bar seem to be working properly now. I just changed the default template to deal with the margin issues as a temporary solution. I’ll post on the Elementor forums if I run into more problems/really want to change my fonts at a later date.

    Thanks!

    Laura

    Theme Author Tom

    (@edge22)

    Glad to hear it’s working properly.

    No problem! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Changes Not Showing/Disappearing’ is closed to new replies.