Support » Plugin: Post Expirator » Changes all posts to draft

  • After I installed the plugin and marked one post expiry, with past date, all posts were so marked. I revised all posts as published. Repeated, marking one post as expired, again, all posts came up expired.

    Any ideas?

Viewing 1 replies (of 1 total)
  • using wp-4.9.1
    If I mark a single post to expire in the future, all posts are marked to expire on this same date, e.g. 2018-01-01. In this case, the post isn’t marked expired, as I stated earlier.

    I set DISABLE_WP_CRON to ‘true’ in wp-settings.php and setup a cron job to run wp-cron.php every 1 minute. That seems to make no difference.

    I created a new post, checking “enable post expiration” with a default +1 month date. When I publish this new post all posts are then given this new expiration date of +1 month – 2018-02-02.

    I created a new post, not checking “enable post expiration”. When I publish this new post, all posts are given an expiry date of “never”, except for 1. Perhaps this one had a date in the past.

    It seems that the post expiration date is getting updated globally, rather than the to the one that should be updated.

Viewing 1 replies (of 1 total)
  • The topic ‘Changes all posts to draft’ is closed to new replies.