iThemes Security (formerly Better WP Security)
Changed wp-content directory--> new uploaded media is corrupted (3 posts)

  1. therandomguy12345
    Posted 2 years ago #

    I installed WP Better Security plugin (which I am loving except for this issue). Like stated in the plugin, after changing wp-content directory name to "*****", all my previously uploaded media had corrupted. The problem is that I uploaded the same media again (after deleting it in wp-admin) and it still remains corrupted.

    I checked through FTP and my wp-content folder has been renamed to "*****" and in the url of all of my media (through wp-admin --> media), the mydomain.com/media/uploads is showing up.

    I'm not sure what's wrong, but I know that it is not good.

    Please respond ASAP. All help is appreciated.


  2. therandomguy12345
    Posted 2 years ago #

    If I click on each image listing (in media tab of wp-admin), it displays perfectly well. The problem occurs when I click the "view" button, look at thumbnails from another page of wp-admin, and on the actual site the images are corrupted.

  3. therandomguy12345
    Posted 2 years ago #

    I was confused about the issue. I have now found the cause, but no solution.

    On the topic of media (I changed wp-content dir. to media using WPBS), I do have Better WP Security installed and I recently turned Enable SSL feature completely off.

    I did this because my hosting plan does not support SSL. Also, all the images on my site are corrupted if you are not logged in (yes, I did re-upload them after changing directory). When I right-click-->open image in new tab, I get an SSL error, so now, I know what's wrong. I went to Media tab of WP-Admin and it turns out that all my image/media urls are using "https" instead of "http" when my site url (general settings) is using "http". I don't have a clue why my media url's are using "https" and I re-uploaded them after disabling SSL, but the same problem occurs.

    I need assistance to change the default media url from "https" to "http" (basically, disabling ssl here). I don't even know how to change the media-url at all (the text field is grayed-out/non-editable).

    I need help as soon as possible, because this issue only occurs when a user is not logged in and those users would be new visitors to the website.

    All help is appreciated.

    P.S.: Just a guess, there may be some added lines of code (by the security plugin) in one of my WP core files. Also, at first, my site url in general settings was set with "https", but I changed about 3 days ago and purged all the cache. Also, I'm not sure if my media originally had https enabled before I completely disabled the feature with WPBS.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.