Support » Plugin: Related Posts by Sovrn » Changed thumbnail size, regenerated, now no images

  • Resolved loulantos



    I changed the size of the thumbnails associated with Related Posts, as 150×150 wasn’t cutting it. After changing, I regenerated the thumbnails, but now the plugin isn’t picking up the new sizes. It’s just displaying the placeholder images. No matter how many regenerations I perform, it seems adamant to ignore them.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hey, thanks for reaching out, I’ll gladly help!

    To what size did you resize your thumbnails to? Smaller or bigger than 150×150? Note that our plugin cannot extract thumbnails smaller than the size you mentioned above, so please try to use bigger ones.

    Anyways — do let me know what’s up, I’m eager to help!

    Take care & have a nice day!


    Hi Silvo,

    Appreciate the response. They’re bigger than 150×150. 240×176 to be exact.

    Hey, thanks for the response!

    Where did you change the size of your thumbnails? Have you also made any CSS customizations in your plugin settings as well? Are you using the Regenerate Thumbnails plugin or some other one?

    Thanks for your feedback!


    I’m using Simple Image Sizes to change the sizes, and then using Simple Image Sizes’ own regenerate thumbnails button.

    Hm, OK, thanks for the detailed answer, but let’s try another way, just to see if it works.

    You can also change the size of your thumbnails if you go to your WordPress’s Dashboard under the tab ‘Settings’-‘Media’ and change the size of your thumbnails to your preferred size (for example let’s use 300×300).

    After that, go to you plugin settings and add the following code into the ‘Customize CSS’ drop-down menu (remember to keep the values [300×300] the same):

    .related_post_title {
    ul.related_post {
    ul.related_post li {
    width: 300px !important;
    height: 300px !important;
    ul.related_post li a {
    ul.related_post li img {
    width: 300px !important;
    height: 300px !important;

    Don’t forget to click on the ‘Save’ button at the bottom of the page, before moving on. 🙂

    The last step is to install the Regenerate Thumbnails plugin, which you can find over here:

    Install it, activate it and hit the Regenerate! button for the finish.

    Let me know how it goes or if the problem persists — I’ll gladly help!

    Take care & have a nice day!


    Hi, I had all the same problems as the guy above, followed all the recommended steps, Regenerate Thumbnails, tried that CSS (which actually breaks the design with the load more posts functionality), uninstall/reinstall Related Posts, etc., and none of that helped.

    I found the problem: the Related Posts plugin hard-codes the thumbnail size to 150 x 150 in the plugin’s config.php. Once I changed that, I was able to get my custom thumbnail size to appear.

    I tracked this down because no matter what I did, including removing the 150px thumbnail options from settings, my functions.php, etc., everywhere, the plugin continually kept pointing to a 150px thumbnail, whether it existed or not. I looked in the wp_post_meta table, meta_key: _wp_attachment_metadata, and saw that the wp_rp_thumbnail was set at 150… even though the “standard” WP “thumbnail” value was set at 266. Which means changing the WP thumbnail setting as described above does nothing, actually.

    I changed all instances of 150 in that key to 266. However, after a reload or 2, it was back to 150. Which meant something was overriding this.

    So, Zemanta, looking for guidance here: is this a bug? Are we doing something wrong? For now, I’ll hard-code your plugin to my 266 value.

    Are you able to instead of hard coding it to 150 make that an option in your plugin? OR… instead of using your wp_rp_thumbnail value, simply use the WP thumbnail value.

    So, after about 5 hours trouble shooting with this plugin, it has one problem after another. After sort of fixing the issue above, now it is showing wrong default static thumbnails. Same issue as described here:

    I also now have installed their other recommended plugin, but the same problems exist.

    Can you drop me a line when you get this sorted out? Just a reply here will do the trick. Thanks, and looking forward to using your plugin when it’s ready.

    Hey Joe, big thanks for your precious input on this matter. And sorry to everyone involved for this recent silent treatment we gave you, but this summer schedule (on all fronts) took its toll. We’re sorry about that, but now we’re back on track.

    As for your inquiry — well, no, it’s not a bug, and yes, we do override the sizes back to 150×150 pixels, since we think that this size fits most needs of blogs out there and we do that in order to avoid any possible technical complications that can occur if we would add that feature.

    We definitely think that this is something that we should work on in the future, but we are also focusing on some other features right now, that are unfortunately keeping us too occupied. As I said, this is something that is on our list, but then again, I cannot make any definite promises as well.

    I hope I was able to shed some light onto the situation we brought ourselves in. As always — you are more than welcome to ask us anything. I sincerely hope I will be able to help you out!

    Take care & have a nice day!


    Hi Silvo,

    Thanks so much for your detailed response. 2 questions:

    1) Is there anyway to set the thumbnail sizes to 266px through your plugin, or should I continue to edit the default from 150 to 266?

    2) Any update on the random default thumbnails showing up? A quick glance from the forum shows roughly 5 people having the same issue. Seems like maybe a bug in the latest version?


    Hey Joe, again, sorry for the late reply! And yes, I’m always ready to explain the mystery ways of how our plugin works. Or — as it is in this case — does not work.

    1.) I’m afraid that you will have to continue to do whatever you are doing to change those sizes of your thumbnails, since there is no automated way to change them permanently via our plugin settings.

    2.) Well, we are planning to fix/modify our thumbnailer sometime in the future, since the task seems a bit harder to get around than we initially thought it would. For the time being, we are only re-directing our users to the previous versions of our plugin (available under the ‘Developers’ tab), or to our other related posts plugins, which are basically the same as this one, they just have a slightly different thumbnailer. It goes without saying that we hope we’ll be able to get it sorted ASAP, but I really cannot make any promises with dates.

    I’m sincerely sorry about that and I’m always ready to help our users get around this thumbnailer problem we’re all experiencing.

    As always — if you have any questions or if you stumble upon any problems (let’s hope not though!), do not hesitate to let me know! I’ll gladly help!

    Take care & have a nice week ahead!


    Hi Joe and Silvo.

    Joe explained the issue pretty well, I was looking for a way to fix this, and to add to what Joe wrote, here’s what you need to do to customize the thumbnail sizes of related posts.

    First, go into the plugin’s config.php (pluginNameFolder/config.php) these lines to whatever width or height amount you want (I chose 200×150, native was 150×150).

    define('WP_RP_THUMBNAILS_NAME', 'wp_rp_thumbnail');
    define('WP_RP_THUMBNAILS_PROP_NAME', 'wp_rp_thumbnail_prop');
    define('WP_RP_THUMBNAILS_WIDTH', 200);
    define('WP_RP_THUMBNAILS_HEIGHT', 150);

    Then, either go to the plugin’s folder pluginNameFolder/static/themes/vertical-m.css and change the widths and/or heights of “ul.related_post li” and “ul.related_post li img” or, better yet, go to the plugin options on your dashoard and there will be an Advanced Settings section where you can change the previous values to the width or height you wish. In my case I changed them to 200×150 as well, and just in case, I went into Settings > Media and chose 200×150 as the thumbnail size.

    Hope that helps the lurkers and everybody else.

    Hey, thanks for your input John, we truly appreciate it, but we did changed our plugin in the meantime, which means that it now supports custom thumbnail sizes by even simpler changes.

    Here’s a simple tutorial we made on our support pages, you are more than welcome to check it out and comment on it, if there’s anything not completely clear:

    I’d love to hear your thoughts — or your questions, if you have any! Thanks again & I’m looking forward to your reply!

    Take care & have a nice day!


    Cool, good to know, Silvo.

    I’ve done it the hard way, so no need to go back myself, but that link will prove useful to other people who can do so easier following your instructions.

    Those instructions by the way, don’t work for me, as my thumbnails aren’t square (eg, 333×333), they’re rectangular (eg, 200×150). I just tried reverting the changes I did and just adding the custom code into the Advanced Settings and it messed up my theme.

    All good though, I just reverted back to the changes I did on config.php and vertical-m.css.

    Hey John, thanks for getting back to me, appreciate it!

    What went wrong exactly with those instructions I provided? The custom thumbnail feature in your plugin settings should also support rectangular thumbnails, not square ones exclusively.

    Were they squeezed somehow or were they missing? When you applied those changes from my instructions, have you left your former changes (config.php, etc.) as they were or have you also reverted them to the default state?

    In any case, let me know, I’m curious what happened. Take care!


    Silvo, it could be due to my custom theme.

    Before attempting just your settings, I reverted back to native values of the plugin (reverted changes done in config.php and the vertical-m.css), and the thumbnails were out of place.

    The only thing I didn’t change was the thumbnail settings on Settings > Media (I kept them at 200×150 in the experiment). But as stated by Joe, that probably didn’t make a difference.

    In either case, all good, it works when I do it my way (config.php and vertical-m.css changes).

    The error could well be on my end, but for the purposes of improving your plugin, if you wish, that is, you can ask for my URL, just contact me at


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Changed thumbnail size, regenerated, now no images’ is closed to new replies.