Support » Developing with WordPress » Changed settings to https; Locked out of WP

  • I am working on installing an SSL certificate on a website at https://shotsbyglenn.com. The website security and caching is being managed through CloudFlare.

    I was told that after the SSL certificate was activated, I would need to change the settings within WordPress under Settings > General to https://shotsbyglenn.com, which I did. After saving those settings, and browsing to https://shotsbyglenn.com/wp-admin, I am being told that there are “too many redirects” and am locked out of the WordPress back end.

    I suspended the SSL certificate through Cloudflare, thinking I would be able to log in at http://shotsbyglenn.com/wp-admin, but that too is not working. I have cleared my cache and my cookies, to no avail.

    Any help you can give me will be greatly appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You should cut the link to CloudFlare and see if the issue is fixed.
    Check out the CloudFlare settings as well and make sure to update stuff to https.

    If you used a plugin for switching things to HTTPS, disable it manually via FTP.

    Let me know how it goes!

    Thread Starter sallen5280

    (@sallen5280)

    I inserted the following lines of code into my wp-config.php file:

    define( ‘WP_SITEURL’, ‘http://shotsbyglenn.com/’ );
    define( ‘WP_HOME’, ‘http://shotsbyglenn.com/’ );

    That fixed the site and I am now able to log in to WordPress Admin. However, when I go to Settings > General, I am no longer able to edit the WordPress Address (URL) and Website Address (URL) lines. They are grayed out, I believe due to the fact that I inserted the above lines of code into my wp-config file.

    So how do I make those lines editable again in WP?

    You`re right. To make the lines editable again, you have to remove the code from wp-config.php.

    You could leave it just for the WP_SITEURL so you can have access to the wp dashboard.

    Thread Starter sallen5280

    (@sallen5280)

    But if I remove the code from wp-config.php, won’t I be locked out of WP again?

    Leave just

    define( ‘WP_HOME’, ‘http://shotsbyglenn.com/’ );

    This way you`ll have access to the wp dashboard.

    Thread Starter sallen5280

    (@sallen5280)

    Actually, leaving just that code blocks me out of the wp dashboard. Leaving the other line of code allows me to log in to the wp admin, but now the WordPress Address (URL) is grayed out and cannot be edited.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Changed settings to https; Locked out of WP’ is closed to new replies.