WordPress.org

Ready to get started?Download WordPress

Forums

Redirection
[resolved] Changed Permalinks and Redirect Stopped Working (1 post)

  1. zenofwordpress
    Member
    Posted 3 years ago #

    I have a new site that is a near duplicate of an old site. I set up redirects on the old site to redirect to the new site. My permalink structure on both sites was /%postname%/%category%/%year%/%monthnum%/%day%/. Everything was working perfectly.

    I decided to change the permalinks on the new site to:
    /%year%/%monthnum%/%category%/%postname%/

    I changed the redirects on the old site from
    source: /(([a-z]|-)+)/(([a-z]|-)+)/2011/([0-9]{2})/([0-9]{2})/?$
    target: http://www.zenofwp.com/{$1}/{$2}/2011/{$3}/{$4}

    to
    source: /(([a-z]|-)+)/(([a-z]|-)+)/2011/([0-9]{2})/([0-9]{2})/?$
    target: http://www.zenofwp.com/2011/{$3}/{$2}/{$1}

    and all I get now is the Not Found page on the new site. And it appears to still be using the old redirect structure.

    This is a valid url from the old site:
    http://www.zenofwordpress.com/widgetized-areas/techniques/2011/03/23/

    Here is the link to the same page on the new site:
    http://www.zenofwp.com/2011/03/techniques/widgetized-areas/

    The valid url from the old site is still redirecting to:
    http://www.zenofwp.com/widgetized-areas/techniques/2011/03/23/
    giving a not found error.

    Any help would be appreciated. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic