WordPress.org

Forums

Changed my website page in options and now i cant log in (5 posts)

  1. li0n
    Member
    Posted 7 years ago #

    Pretty straight forward, as the title says, I changed my website options from "downloaditall.net/" to "downloaditall.net/index.php" because my index.html file is now an opt-in page (Sorry, not trying to spam here at all, this is a legit problem).

    Anyway, now I can't login to my site.

    Is there a way I can edit my php settings in my database to change it back to the original site?

    I don't want to reinstall my blog.

    Thanks!

  2. moshu
    Member
    Posted 7 years ago #

    1. Those two URLs can NEVER end with a filename. Omly directory name.
    2. No, you can NOT have 2 index files in the same directory. It will never work!
    3. In the database change the "site_url" AND "home" values in the wp-options table.

  3. li0n
    Member
    Posted 7 years ago #

    Awesome, thanks

  4. li0n
    Member
    Posted 7 years ago #

    1 more question:

    Is it possible to move my whole wordpress blog to a new folder and then rename everything in some batch fashion?

    I'm willing to do all the personal PHP table editing.

    Again, thanks Moshu.

    I want to have my own index.html file and have it then access the blog.

    Cheers

  5. moshu
    Member
    Posted 7 years ago #

    If you want to move - you will find all the necessary info in the Docs: Moving_WordPress

    If you are not obsessed by the index.html... you may want to consider using WP's built-in feature to create a "static" frontpage and another page for your posts.
    Visit your own admin panel > Settings (or Options in pre-2.5) > Reading. You can set there two existing(!) Pages as front and posts, respectively.

Topic Closed

This topic has been closed to new replies.

About this Topic