Support » Fixing WordPress » Changed in a line in the wp-rss2.php file…

  • ..and now my installation of WordPress is completely broken. I tried to force the encoding, and moved the

    <?xml version="1.0" encoding="UTF-8"?>

    to the top of the document. Trouble ensued. Firefox and IE display nothing at all. Opera displays random ASCII characters. Utter garbage. I returned the file back to it’s proper set up, even copied over a fresh version of the file from the archive on this site.

    No fix.

    I tried to upgrade WordPress to the newest version, and it says my database needs to be upgraded. Well, I can’t get to that page, for it shows the same garbage as every other page does. is my website is the file I edited… yields the database needs to be upgraded error (/admin/ is a redirect)

    I have just put up a very crude page explaining what is wrong. will show the problem as it currently stands..


Viewing 2 replies - 1 through 2 (of 2 total)
  • if you have access to phpMyAdmin dump the data and structure separately of the existing database, then do a fresh install of WP (following the standard upgrade procedures, save your wp-content folder mainly), after fresh install is done, re-install any plugins you were using, add and activate your theme. then ‘restore’ the old data using phpMyAdmin SQL window. you may need to restore the data one table at a time depening on what columns, etc have been created by plugins, etc.

    ….disregard above, i just went clicking around your links above, and it looks like everything might be OK, go to and login (note you may need to re-set your password), disable all plugins, it looks like it’s simply a problem with a plugin.

    once they’re all disabled, enable them one by one, if the problem happens again, you’ve found the plugin causing the problem.

    also be sure to check your configuration, site paths, etc. as well as your permalink structure, .htaccess file and permissions on .htaccess


    OK, I have no idea how the database suddenly became usable. WordPress was complaining, last night, that the database was out of date and that I needed to upgrade. Running the upgraded.php, however, returned garbage.

    I disabled all the plugins and found mtdewvirus’ Recent Comments plugin to be at fault. I start enabling plugins, one by one. Everything was fine, except nothing showed on my main page. I went to another theme of mine, worked perfectly. Toggled a few plugins on and off, and now the WP-Cut plugin is giving me issues.

    I’ve been using both of these plugins constantly for the past few months.. why would they suddenly start doing this when I simply edited the wp-rss2.php file?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Changed in a line in the wp-rss2.php file…’ is closed to new replies.