Support » Fixing WordPress » Changed Hosts – big problem!!!

  • Hi All,

    I was having consistent problems with using GoDaddy as a host so I was convinced by reading along the forum to switch over last night. I switched to Dreamhost and thought all was fine but…not quite.

    I have two installations of WP on my database. I created the two databases by changing the table names as opposed to making another database. the wp_ installation is for my domain poppawasapimp.com and i have a premium_ table created for poppawasapimp.com/premium. Everything was running smooth before I switched hosts.

    I backed up all files with ftp and the database backed up both table prefixes wp_ and premium_. I imported the database and redirecte the DNS but when I now go to poppawasaapimp.com i get the poppawasapimp.com/premium page as if poppawasapimp.com does not exist! I don’t know what could be wrong. Can anyone advise what I could do to fix this at this point?

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • If your two original databases used the same $table_prefix (as defined in wp-config.php) then I’d recommend creating two databases at Dreamhost and import the tables accordingly.

    Resources
    Moving WordPress
    Restoring_Your_Database_From_Backup

    Thanks Michael,

    The two original installations used different prefixes within the one sql database. It looks just like it did with the old host but no luck!

    So, I should create an additional database to import my domain.com/premium tables and keep the domain.com database tables seperate? Once I do this, I still just FTP all the domain.com/premium files into that domain.com/premium directory? Or would I have a separate FTP for it and would have to redirect it somehow?

    (sorry if I wrote my question confusing…I couldn’t think of a cleaner way to word it)

    -Derrick

    Well you should have a different directory for each domain. And then you would uploaded the wordpress files to both folders.

    Uploading WordPress to a remote host

    I had this same problem (with another host). It turned out that in their configuration, I was not given the option of creating a separate sign in for the second wp db (which used a different prefix but the same schema tables). When I called the host, it took them only a couple of minutes to create the separate login.

    Don’t know if this will help you at Dreamhost or not, but maybe it will help someone.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Changed Hosts – big problem!!!’ is closed to new replies.