[resolved] Changed domain password & cant access the blog (5 posts)

  1. sd9sd
    Posted 8 years ago #

    Hi Everyone,

    The blog to my website had its own login and password, and the domain login & password were different. But ever since I changed the domain password, I'm not able to access the blog.

    It shows the following error message:

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.
    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    The wp-config.php file is empty (it was empty when the blog was working too).
    Do I have to enter the new password in the WP section of cpanel? There, it asks for a new directory. Will the old blog information get erased if I choose a new directory?

    Please help out....

  2. Jeremy Clark
    Posted 8 years ago #

    The wp-config.php file is empty (it was empty when the blog was working too)
    No it wasn't.
    You need to obtain a copy of the wp-config.php file from the original zip file you installed with and copy it into the root directory of your wordpress installation and edit it with the database information.

  3. sd9sd
    Posted 8 years ago #

    I have a local copy of all files that are in the remote folder. Its the local copy I checked...which was empty. Will check the original zip file too....

    But is the problem because of the wp-config.php file or some other problem?

  4. MichaelH
    Posted 8 years ago #

    Error establishing a database connection

    That message is a result of wrong values in wp-config.php or the database server/computer itself is down.

  5. sd9sd
    Posted 8 years ago #

    Sorry guys, its my mistake.....I tried to open the wp-config.php file in dreamweaver (dreamweaver showed the file as empty) but when I opened it in notepad, it worked fine.
    All I had to do was to replace the old password with the new one. Now everything is working fine!
    Thanks a lot jeremyclark13 & MichaelH. This forum is great! Never expected a response this fast and sincere :)

    Thanks a million!!! :)

Topic Closed

This topic has been closed to new replies.

About this Topic