Support » Fixing WordPress » Changed blog url – Did work – Now functions.php line 502 error No dashboard

  • Hello – I have a problem and sure do need help, please. Could this be a simple problem anyone could direct me to? Problem site:

    I changed the blog url and everything was working fine at first. I also successfully and updated the tables in phpMyAdmin to the new url. I had logged in and checked some things in settings, but they were already updated.

    Also – Read the helpful links on the support forum about moving blogs and changed the functions.php file by adding the 2 lines with appropriate relevant new url text changes:


    It pulled up everything fine except for the internal media photos.

    So this morning I was investigating how to update the internal links so I would not have to change all those photo urls individually. I saw the link to the velvet-blue plugin, which was not shown to be working up to 2.9.2 but I tried it anyway.

    Coincidentally or not – after activating and then clicking on the option to change the internal links, I got this:

    Fatal error: Call to a member function escape() on a non-object in /home/content/57/5042657/html/MountainRidgeRealty/wp-includes/functions.php on line 502

    I *think* upon my first reload immediately after selecting ‘internal links’ – is when the dashboard became inaccessible, even typing in the login file etc.

    So I renamed the plugin – but the error and inability to pull up the site persists. Also renamed the entire plugins directory hoping to deactivate any problem, no difference, so named it back again.

    I checked the functions.php file and tried removing and then replacing the two added lines, as the wordpress instructions direct you to remove them once the site works (why, I don’t understand). When I tried removing them as an experiment after I had the above problems, I got just a blank white page, no 502 error, so I put them back, and the 502 error is back. I then repeated the process using the functions.php from ‘before’ yesterday’s move, adding the two lines back in.

    Since then – I rechecked my urls in the database which appear to be correct and unchanged by any of this morning’s fatal experiments.

    I have also manually changed the wp_meta posts in the db to all the correct urls, in case the error was because all those hundred or so the thumbnails on many posts were throwing an error.

    I backed up the database first and the config, htaccess and functions files only. I have replaced those, to no avail.

    The only things I can remember I was doing this morning when the problem occurred was I had shortly before updated wp to 2.9.2 (and it reloaded ok), then I installed that plugin and had clicked on the option to update the internal links (this was right before the lock-out).

    There are only two files that show a date-stamp change on the server since everything worked this morning:

    .htaccess (this because I downloaded and renamed it just to have a look at it; all I saw in there was super-cache stuff.

    – and the functions.php file

    Also deleted/renamed the cache file.

    Thank you very much in advance for your help ‚ô¶from Catherine.

Viewing 2 replies - 1 through 2 (of 2 total)

    I never could get an answer anywhere, and I can’t code php. After setting it aside for a few days, I kept coming back to the functions.php error being the clue.

    So I simply replaced a fresh downloaded functions.php document for the old one, and it worked like a CHARM. Clearly the replacement functions.php file from earlier that I attempted to swap out after renaming was somehow flawed. My edits and adding those 2 lines might be the cause of the trouble, but what matters to me of course is that it works, I can get in the dashboard, and now I can finish the updating process for the images.

    So easy this time!

    I need to add a short PS on this by way of acknowledging that I did receive some help after all, if I had been tuned in deep enough to pick up on it. I went back after posting this and saw where a senior expert had offered the simple suggestion of replacing the functions.php file. Since I did do that with the earlier file version that worked previously, I discarded that solution and then completely forgot about it. Perhaps it stuck in my subconscious and after some time and space floated to the forefront. What worked this time was using an absolutely clean version, not a used, possibly corrupted version. Hope this helps.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Changed blog url – Did work – Now functions.php line 502 error No dashboard’ is closed to new replies.