Support » Fixing WordPress » Changed A Record, Only Home Page Link is Correct Now

  • Resolved cgl102770

    (@cgl102770)


    Hi – Primitymedical.com was hosted with godaddy. I pointed the A record to my bluehost account, but intentionally kept the mx records pointed to godaddy so as not to change where emails hosted.

    I already had a test site created for Primity at christianleonard.com/primitymedical. When I pointed the A Record to that bluehost accounts ip, primitymedical.com started to show the test site I created. That worked correctly, though the other pages dont show, for example, primitymedical.com/contact, they show christianleonard.com/primitymedical/contact. I cant change the permalinks in wordpress because it wont let me delete the christianleonard.com part. Is there a way to have all of the non-home pages show primitymedical.com in their root url, or do I need to delete the site and reinstall? Thank you for any suggestions.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello, cgl102770, & welcome. These changes can become complex, that’s for sure.

    Firstly, do you have your primitymedical.com pointed to christianleonard.com/primitymedical in your Bluehost control panel? If not, you could either do that, or you could actually just move the WordPress install to a folder like primitymedical.com.

    If you move the install, then, to eliminate the christianleonard.com/primitymedical permalinks, you can do a search & replace on the database & eliminate references to christianleonard.com. Please back up your database, & please ensure that your user content is located appropriately, ie, in primitymedical.com, if that’s where you moved the install.

    To do a database search, I personally use:
    https://interconnectit.com › Products › Database Search and Replace Script in PHP
    but there are a variety of plugins that you can use.

    Please let us know if we may assist further.

    Thank you for the reply. Yes, the Primity site is installed in a folder named primitymedical. I have the Godaddy A Record pointing to the Bluehost ip address. I also added the domain primitymedical.com in the Bluehost cpanel, and it was accepted. So, when one types in primitymedical.com in their browser, it shows the new correct site hosted on my bluehost account. However, when someone clicks the other pages, they still show christianleonard.com/about, or christianleonard.com/contact, etc.

    Sorry if I’m being redundant, but I believe I’ve done everything you suggested except the database search/replace, so I will look up those plugins now. Thank you for your reply.

    Editing the urls in settings > general and removing my root hosting domain did the trick.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Changed A Record, Only Home Page Link is Correct Now’ is closed to new replies.