Support » Plugin: Easy Digital Downloads - Simple eCommerce for Selling Digital Files » change wp-content path and get 403 for download

  • Resolved dehkadeh wp

    (@dehkadehwp)


    Hi,

    I have changed wp-content path by following code in wp-config:

    define( ‘WP_CONTENT_DIR’, $_SERVER[“DOCUMENT_ROOT”] . ‘/files’ );
    define( ‘WP_CONTENT_URL’, ‘https://files.site.com’ );
    define( ‘COOKIE_DOMAIN’, ‘https://site.com’ );

    All things working fine. Just there is problem for download edd files in force method. I get error 403 forbidden (method redirect works fine but is unsecured).

    Can you help for this?

    Thank you very much

    ### Begin System Info ###

    — Site Info

    Site URL: https://site.com
    Home URL: https://site.com
    Multisite: No

    — Hosting Provider

    Host: DBH: localhost, SRV: site.com

    — User Browser

    Platform: Windows
    Browser Name: Chrome
    Browser Version: 66.0.3359.139
    User Agent String: Mozilla/5.0 (Windows NT 10.0; Wi
    n64; x64) AppleWebKit/537.36 (KH
    TML, like Gecko) Chrome/66.0.335
    9.139 Safari/537.36

    — WordPress Configuration

    Version: 4.9.5
    Language: fa_IR
    Permalink Structure: /%category%/%postname%/
    Active Theme: theme-name 1.0
    Show On Front: page
    Page On Front: site.com (#11)
    Page For Posts: Unset
    ABSPATH: /home/dehkade1/public_html/
    Remote Post: wp_remote_post() works
    Table Prefix: Length: 8 Status: Acceptable
    WP_DEBUG: Disabled
    Memory Limit: 40M
    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit, refunded, failed, revoked, abandoned, processing, active, inactive

    — EDD Configuration

    Version: 2.9.1
    Upgraded From: 2.9
    Test Mode: Disabled
    AJAX: Enabled
    Guest Checkout: Enabled
    Symlinks: Disabled
    Download Method: Direct
    Currency Code: dollar
    Currency Position: after
    Decimal Separator: .
    Thousands Separator: ,
    Upgrades Completed: upgrade_payment_taxes,upgrade_customer_payments_association,upgrade_user_api_keys,remove_refunded_sale_logs
    Download Link Expiration: 24 hour(s)

    — EDD Page Configuration

    Checkout: Valid
    Checkout Page: https://site.com/dashboard/checkout/
    Success Page: https://site.com/dashboard/checkout/purchase-confirmation/
    Failure Page: https://site.com/dashboard/checkout/transaction-failed/
    Downloads Slug: /downloads

    — EDD Gateway Configuration

    Enabled Gateways: xxxxx, Wallet
    Default Gateway: xxxxx

    — EDD Tax Configuration

    Taxes: Disabled
    Tax Rate: 0
    Display On Checkout: Not Displayed
    Prices Include Tax: No

    — WordPress Active Plugins

    Contact Form 7: 5.0.1
    Crayon Syntax Highlighter: 2.8.4
    Easy Digital Downloads: 2.9.1
    Easy Digital Downloads – Wallet: 1.1.4
    Invisible reCaptcha: 1.2.1
    reSmush.it Image Optimizer: 0.1.15
    Yoast SEO: 7.4.2

    — WordPress Inactive Plugins

    — Webserver Configuration

    PHP Version: 7.2.5
    MySQL Version: 5.6.38
    Webserver Info: LiteSpeed

    — PHP Configuration

    Memory Limit: 256M
    Upload Max Size: 32M
    Post Max Size: 32M
    Upload Max Filesize: 32M
    Time Limit: 60
    Max Input Vars: 1000
    Display Errors: N/A
    PHP Arg Separator: &

    — PHP Extensions

    cURL: Supported
    fsockopen: Supported
    SOAP Client: Installed
    Suhosin: Not Installed

    — Session Configuration

    EDD Use Sessions: Enabled
    Session: Enabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /var/cpanel/php/sessions/ea-php70
    Use Cookies: On
    Use Only Cookies: On

    ### End System Info ###

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Pippin Williamson

    (@mordauk)

    Have you re-uploaded your files after making the change?

    Thread Starter dehkadeh wp

    (@dehkadehwp)

    No. I have changed files address in database.
    I do not uploaded edd files in wp media. I uploaded them manually in uploads/edd folder and put it’s address for edd download.

    Thread Starter dehkadeh wp

    (@dehkadehwp)

    Files address is correct and redirect method works fine but force method not works. (before changing wp-content folder, force method worked fine)

    Dear Pippin, Thank you for your response. I love you 🙂

    Plugin Contributor Pippin Williamson

    (@mordauk)

    Could you please upload a file through EDD and then see if it has the same behavior?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘change wp-content path and get 403 for download’ is closed to new replies.