change "wordpress" folder name to "blog" (7 posts)

  1. bluwizz
    Posted 7 years ago #

    wordpress is in http://www.mydomain.com/wordpress.

    I want to change to mydomain/blog. using cPanel I changed the folder "wordpress to "blog" then changed my code in mydomain.
    This did not work, could not see the blog. Changed back to mydomain.com/wordpress - then was able to access my blog.

    Went into Options and changed the urls there to mydomain.com/blog and went back and changed the folder and program links from wordpress to blog figuring that that should fix the problem.

    Wrong again, now i can see the posts without the basic structure of wordpress. I had to use phpMyAdmin to go into the Dbase and change Options back to mydomain.com/wordpress and then back into cPanel to change the folder back to wordpress and the program links.

    Ok, I know this can be done yet I need some help/direction to whatever it is that I am missing. It seems that it should be simple, what am I missing?

  2. noelgreen
    Posted 7 years ago #

    This is a tricky thing to do because you have to do it in the right order. Here's how I do it... and I'm not promising this will work for you.

    1) Login to your wp-admin and go to your Options.
    2) Type in your new path (in your case mydomain.com/blog)
    3) Save it. (you will / should get an error)
    4) Go to your CPanel or FTP and rename the folder to match.
    5) Go to the new wp-admin url (mydomain.com/blog/wp-admin/) It SHOULD come up now.

    Let me know if it doesn't... if it doesn't, or if you have posts showing but no images, it's because you have hard coded links to the images inside your blog. If that's the case you need to make sure they're all relative links in your theme and then also download and use the search and replace plug-in to search all your blog entries and change "mydomain.com/wordpress" to "mydomain.com/blog".

    Hope that helps!

  3. bluwizz
    Posted 7 years ago #

    Thank You NoelGreen,

    Followed your procedure to the letter and it worked just fine! I had the right idea only it appears I got my timing orders out of sync.
    Situation resolved!

    Thanks again


  4. noelgreen
    Posted 7 years ago #


    Glad it worked... like I said, it's very temperamental as to the exact order you have to do it.

    You should mark this form as "resolved" so others can find it easily.

  5. Majik_Imaje
    Posted 7 years ago #

    I had a different idea, I renamed the wp-admin folder itself

    but first I had to do it in the php files, every instance of wp-admin was replaced with my new directory name = wp-dadmine

  6. raz786
    Posted 7 years ago #

    Thanks noelgreen & thanks web search engines...cause without them I would have never found this solution!

  7. sarahd
    Posted 7 years ago #

    2 more cents: Sometimes the .htaccess file can cause problems and needs to be cleared.

Topic Closed

This topic has been closed to new replies.

About this Topic