• Resolved merock

    (@merock)


    Hi guys.

    I need to change the way the totals are shown on the invoices but I don’t understand if there really is a way to do it or how to do it.

    Right now, the invoices totals are like that:

    Subtotal:
    Shipping:
    TOTAL (with shipping and 21% tax incl.):
    ———————————
    But starting the 1st of Jan by law in my country it needs to show tax separately, this way:

    Subtotal:
    Tax (21%):
    Shipping:
    TOTAL (with shipping + 21% tax incl.):
    ———————————

    How can I do this? I’ve tried to edit the template but without success.
    Thanks in advance for your help 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Yordan Soares

    (@yordansoares)

    Hi @merock,

    This is certainly possible using Premium Templates. This extension includes a customizer that allows you to tailor your PDF documents using product columns and total rows blocks, as well as custom blocks that you can place in different areas of the document (currently 19 different ones).  The customizer also allows you to sort items by product name, SKU and category. In addition, Premium Templates provides two additional templates: Business and Modern.

    For your specific case, you just need to add a new VAT block in the total rows, like this:

    A screenshot that display a VAT total row using the customizer

    Since this is a premium plugin, and WordPress doesn’t allow us to provide support or answer pre-sale questions for paid plugins in this forum, please contact us by email if you have more questions about it: support@wpovernight.com

    Thread Starter merock

    (@merock)

    Hey Yordan,

    Thx for your answer!!!

    I just want to know how to stop showing the total and tax combined. I want to show it separately in the invoice.

    —–

    SUBTOTAL:
    SHIPPING:
    TAX(21%): X,XX€
    TOTAL: X,XX€

    instead of:

    SUBTOTAL:
    SHIPPING:
    TOTAL: X,XX€ (INCLUDING X,XX€ TAX(21%)).

    ——

    How can I edit the invoice.php to just change this detail?
    I don’t think I need a customizer for this????

    Let me know 🙂
    Bests!

    Plugin Contributor Yordan Soares

    (@yordansoares)

    Thanks for clarification @merock. I misunderstood your request in your first message.

    To display the VAT itemized, you need to have set the checkout to show prices excluding tax. This should be done under WooCommerce > Settings > Tax > Display prices during cart and checkout, choose Excluding tax here.

    Let me know if this is what you wanted 🙂

    Thread Starter merock

    (@merock)

    Hey Yordan,

    Seems not working… nothing changed. The (including 21%tax) line has gone from the TOTAL but its not showing up as a separate line.

    Now it shows like that

    Subtotal 00,00€
    Shipping 00,00€
    Total 00,00€

    We miss the TAX line. Must be like this:

    Subtotal 00,00€
    Shipping 00,00€
    Tax 00,00€
    Total 00,00€

    I’m sure is pretty simple but I can’t find how to do it damn hahah.
    Any idea??

    Thx for your support Yordan.

    Plugin Contributor Yordan Soares

    (@yordansoares)

    Hi @merock,

    Sorry for the late reply! We were away for Christmas holidays! By the way, Happy New Year!

    After sending the recommendations above, it was brought to my attention that it is against the law in many EU countries to show prices excluding tax in the checkout, so please double check if this is desired in your situation.

    If this is no problem for you, please create a fresh test order in WooCommerce (preferably via the checkout) with those settings, and make sure that taxes were charged for the order in the first place (See Displaying taxes).

    Our free plugin will always follow the WooCommerce settings. But if you need to change the output of the PDF independently from the order and checkout, then our Premium Templates extension is the way to go.

    Thread Starter merock

    (@merock)

    No worries, we made it! 🙂
    Thx for your help yordan.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Change totals’ is closed to new replies.