[resolved] Change title color (7 posts)

  1. Taiz
    Posted 6 years ago #

    This is my Homepage and I can't change the color of the title to #000000. I've tried changing every color entry in the CSS. It only turns to black after clicking on it now. It seems the CSS is being overwritten somewhere. The theme I use is Simplr, by Scott. I couldn't find answers in other entries on this topic on the wp forum. Help is much appreciated!

  2. Peter Boosten
    Posted 6 years ago #

    Line 10 of your style.css:

    a, a:link {


  3. Taiz
    Posted 6 years ago #

    But that changes ALL the links into black, and that's not what I want. Homepage again.

  4. Arnold Goodway
    Posted 6 years ago #

    The setting is being overwritten because the title is a link. To change the color you will have to set the different link states for the h1 heading you are using. You will have to set the following elements to whatever you require:

    div#header h1#blog-title a:link{color:#000,text-decoration:none}
    div#header h1#blog-title a:visited{color:#000,text-decoration:none}
    div#header h1#blog-title a:hover{color:#000,text-decoration:none}
    div#header h1#blog-title a:active{color:#000,text-decoration:none}

    By changing all the link states you could add different effects to the title.

  5. Taiz
    Posted 6 years ago #

    Thanks for your reply. But where do I do this? This is from the css:

      div#header{margin:9em 0 7em;text-align:center;}
      div#header h1#blog-title{font-color:#000000;font-size:3em;line-height:133%;margin:0;font-weight:normal;}
      div#header div#blog-description{font-size:1.2em;line-height:133%;text-align:center;color:#000000}

    Here all the color entries are already black.

  6. Arnold Goodway
    Posted 6 years ago #

    You simply add this to your stylesheet. All your settings are already black but you have not included the link state settings. Remember you can change the colors to anything you want to in the different link states.

  7. Taiz
    Posted 6 years ago #

    It worked! Wonderful, thank you very much for your time.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.