Support » Fixing WordPress » Change theme manually – by cpanel or phpmyadmin

  • Resolved carowinemary

    (@carowinemary)


    Hi there

    Did a stupid thing trying to update my theme and now I’m getting this error:

    Warning: require_once(/home/g—–5/public_html/wp-content/themes/spruce copy/lib/admin/metaboxes/metaboxes-init.php) [function.require-once]: failed to open stream: No such file or directory in /home/g—–5/public_html/wp-content/themes/spruce copy/functions.php on line 145

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/g—–5/public_html/wp-content/themes/spruce copy/lib/admin/metaboxes/metaboxes-init.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/g—–5/public_html/wp-content/themes/spruce copy/functions.php on line 145

    I tried to upload a copy of the theme, labeling it <spruce copy>, which clearly had errors. So I deleted the copied theme and want to go back to the previous version of the them <spruce>, which is still on the site.

    Assuming I have to go to PhpMyAdmin to change it back – would anyone be able to let me know what, and how?

    Thanks, Caroline

Viewing 3 replies - 1 through 3 (of 3 total)
  • I should mention, I have gone into PhpMyAdmin and made sure all of the following are correct:

    Under wp-options:
    I made sure that all the following lines have the right theme selected, <spruce>
    Line 45 template
    Line 46 stylesheet
    Line 1780 current_theme

    Still no change. Any other suggestions?

    The problem is not in the code. The issue is that the file “metaboxes-init.php” is missing, or is in not where WordPress expects to find it (wp-content/themes/spruce copy/lib/admin/metaboxes/). Good luck.

    Fixed this by uploading a renamed new version of the theme…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Change theme manually – by cpanel or phpmyadmin’ is closed to new replies.