Support » Theme: Gazette » change text color?

  • Resolved westerngeomancy

    (@westerngeomancy)


    I’m not sure if this is a theme issue or a Woocommerce one… on my shop page, if I have sale items, the secondary text color is currently showing white on grey background and is nearly impossible to see.
    How can I change this to something more legible?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m not seeing that currently, but right now I’m seeing Minileven as your theme. If you want to switch back, we can likely help you find some CSS to change the colors. Let us know.

    I don’t understand – the theme is Gazette, not Minileven.
    If you look at the page link I posted, look to the right of the price (in green) – the sale price shows in white text; that’s what I need to change.

    Hi @westerngeomancy,

    There’s a combination of overlapping issues.

    Logged-out visitors, such as @supernovia and I, see the mobile theme from Jetpack (minieleven), not Gazette, when viewing the link you posted. However, other pages on the site appear correctly.

    Screenshot:

    This appears to be happening due to WP Fastest Cache incorrectly caching the mobile version of the site on some single product pages.

    You might see something different if your are logged in and viewing a non-cached version.

    Please:

    • Delete the cache in WP Fastest Cache’s settings
    • Temporarily disable WP Fastest Cache
    • Disable the mobile theme in Jetpack’s setting (it’s unnecessary because Gazette is responsive) in Jetpack > Settings > Writing tab > Theme Enhancements

    Once those steps have been done, all visitors should see the correct theme.

    To change the text colour, please try adding the CSS below to the Customizer in Appearance > Customize > Additional CSS:

    ins .woocommerce-Price-amount {
        color: #77a464;
    }

    If everything then appears correctly, you can reactivate WP Fastest Cache.

    If it doesn’t appear correctly, please keep the caching plugin disabled so that we can troubleshoot the issue further.

    Thank you @gary-barrett !

    Thank you @gary-barrett – that’s solved the issue for me, and hopefully for other users too.
    Many thanks!

    (Marking as resolved)

    You’re welcome, glad I could help 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.