WordPress.org

Support

Support » Plugins and Hacks » Change "staff-member/" to something else

Change "staff-member/" to something else

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Brett Shumaker
    Member

    @brettshumaker

    On line 141 of simple-staff-list.php, when I’m setting up the staff-member custom post type I set the slug with
    'rewrite' => array('slug'=>'staff-members','with_front'=>false),

    Change that to:
    'rewrite' => array('slug'=>'people','with_front'=>false),

    gsbrock
    Member

    @gsbrock

    Just a note, having this as a user-definable slug without having to edit the plugin source would be very cool, especially if it could be configured to persist through plugin updates!

    esaner
    Participant

    @esaner

    When I do this I get a page not found error when viewing individual staff pages. Anyone else have this problem? Fixes?

    esaner
    Participant

    @esaner

    Ah. The error is because the slug cannot be the same as the page permalink for the page where the [simple-staff-list] shortcode is entered.

    See here: http://wordpress.org/support/topic/pages-and-custom-types-cannot-have-the-same-name-so-how-to-structure-permalinks?replies=20

    esaner
    Participant

    @esaner

    What happens is that WP looks for an archive of the simple staff list custom post type at http://www.example.com/‘slug’ and never sees the page with the same permalink.

    To get around this, I created an archive page in my child theme(archive-simple-staff-list.php) and called the short code with:

    echo do_shortcode(‘[simple-staff-list]’)

    Works great.

    esaner
    Participant

    @esaner

    When changing the URL slug, you may also want to change line 113, which sets the page title in the header and the browser tab title.

    ‘name’ => _x(‘Staff Members’, ‘post type general name’),

    I’ve changed line 141 as suggested and that does indeed change the permalink but as esaner discovered, the individual staff pages are now not found. I haven’t even created a page to list the staff yet, so I don’t think it’s a problem with the slugs being the same? Any help much appreciated!

    Please ignore my last post, it was my own stupid mistake. I might as well confess it – mod_rewrite was not enabled. I know, like it said, stupid mistake! But I’m working on a different server and in my haste to get a staff plugin working I never bothered to check any other urls first!

    I would like to be able to show only the first say 50 words of each bio when using the simple-staff-list shortcode, with a ‘read more’ link.

    I’ve got a read more link working, but I can’t figure out a nice way of only showing part of the bio. I could modify the plugin I suppose but I’d prefer not to… Anyone suggest a neat way to show just part of each bio?

    just realised I posted in the wrong place, sorry (new-ish to WordPress)

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Change "staff-member/" to something else’ is closed to new replies.