Support » Plugin: WP Hide & Security Enhancer » Change plugins folder back to original…

  • Hey, great plugin!

    Having little issue with another plugin not liking the custom plugin folder name. Need to do some trouble shooting.

    In Rewrite/Plugins/New Plugins Path I changed to custom name and all working.

    I tried to change the custom name BACK to “plugins” using -New Plugins Path- field and lost all plugins. Had to change back to the custom name and reactivate all plugins…

    BTW: even tried removing offending lines to htaccess but still did not work.

    Do not want a full reset, really enjoying the plugin and just need to do some troubleshooting:)

    SO, what is the correct method for just resetting custom plugin folder back to default? Do not want to lose all plugins and have to reactive…

    Thanks for your time.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Also tried https://wordpress.org/support/topic/how-to-disable-the-plugin-when-lost-access-to-admin-dashboard/

    This results in all plugins being disabled. As noted I used a custom plugin folder name. I changed plugin folder back to plugins and this is when all plugins get disabled.

    Where is the custom plugin folder name stored? Can’t get rid of it by following your directions to disable above.

    Real pain to be stuck like this…

    Plugin Author tdgu

    (@tdgu)

    Hi,
    Sorry for the issue.
    Once you changed any plugin option it will reflect on the dashboard/front side. As mentioned above, you can change the default Plugins url at Rewrite > Plugins.

    Ensure you cleared the site cache on any plugin option change. Also check if the url changed on admin dashboard and on front side.

    Thanks

    “Ensure you cleared the site cache on any plugin option change. Also check if the url changed on admin dashboard and on front side.”

    Thanks for reply.

    I am not running a cache plugin on site at this time (new site in dev). Using cloudflare but it is in DEV mode and not caching.

    But, every time I attempt to disable WP Hide & Security Enhancer plugin, rename plugin folder back to “plugins” and remove WP Hide & Security Enhancer content from .htaccess all plugins disappear from dashboard. Get the message they are disabled because not found.

    Once I rename the plugins folder back to custom name, all plugins reappear but have to the reactivated. Really frustrating trying to figure this out.

    On another note: Did find what was causing the other plugin to stop working after installing WP Hide & Security Enhancer. The line near top of htaccess that begins with #. I remove that my other plugin works fine but of course WP Hide & Security Enhancer cannot then update htaccess.

    Plugin Author tdgu

    (@tdgu)

    I’am not sure i understand correctly, but you actually re-name the plugins folder through ftp/file manager? is this what you meant? You don’t need to do that or it will break the site functionality.

    Any lines which starts with a # char, on .htaccess file, are just comments and not being parsed by Apache.

    If can’t figure out the problem, feel free to contact us directly and i’ll help further.

    Thanks

    “I’am not sure i understand correctly, but you actually re-name the plugins folder through ftp/file manager? is this what you meant? You don’t need to do that or it will break the site functionality.”

    I only rename via ftp AFTER removing the plugin and htaccess content that you plugin writes. Fail to see how that would be wrong, but please enlighten me how?

    “Any lines which starts with a # char, on .htaccess file, are just comments and not being parsed by Apache.”

    Does your plugin write string like this in htaccess: #WriteCheckString:1566068409_97418 ???

    Plugin Author tdgu

    (@tdgu)

    Does your plugin write string like this in htaccess: #WriteCheckString:1566068409_97418 ???

    Yes, but this is just a comment line, not being render by Apache.

    Yes, but this is just a comment line, not being render by Apache.

    Yes, I understand what it means and it is not rendered by apache.

    But, causing issues. You have:

    #WriteCheckString:1566068409_97418

    For some reason some plugins do not like #WriteCheckString:1566068409_97418. If I change to standard and recommended:

    # WriteCheckString:1566068409_97418 (note space after #)

    My plugins that do not work with your plugin installed start working.

    But you plugin stop working. Cannot update htaccess.

    Plugin Author tdgu

    (@tdgu)

    I see your point. Can you send some plugins title which are not working with this? I’ll try to figure out what’s going on as might be something else.

    Thanks

    Awe man, this went on too long and I have now left for trip. Do not have list of plugins but one of them was InstaMember (paid membership plugin). There were a couple of free ones but name has now escaped my old brain:) Be happy to get the names when I return end of September.

    But, I fixed my issue by simply changing your plugin classes to write:

    # WriteCheckString:

    and not

    #WriteCheckString

    No ill effects that I could find.

    Thanks!

    Plugin Author tdgu

    (@tdgu)

    Ah i don’t have access to that plugin, so please do send some plugin titles when get back from your trip 🙂
    Enjoy your trip.

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.