WordPress.org

Ready to get started?Download WordPress

Forums

Follow
Change permalinks 'URL/subscribe' for the 'URL/page number' in Follow Plugin (3 posts)

  1. MMM-2012
    Member
    Posted 2 years ago #

    Hello,

    Thanks for your great plugin!
    We all love to have a follow button on our blogs!

    I expect I have a problem with the link to page 'subscribe' with error message: 'The requested URL /subscribe/ was not found on this server'

    because my site on wordpress.org use permalinks with numbers of page like: http://www.melimelomok.com/?p=123

    Is it posible to change the name of page 'subscribe' for number of page?

    Please help me, this is my first site on WP. Thanks.

    http://wordpress.org/extend/plugins/follow/

  2. NoProbRob911
    Member
    Posted 2 years ago #

    I am not the author, but maybe I can help...

    If you absolutely must use the non-pretty permalinks, and if this plugin author does not respond with a solution for you, you could do one of the following klunky fixes:

    • Put a redirect into the .htaccess file to redirect /subscribe/ to ?p=123.
    • Create a subdirectory (folder) named subscribe in the root of your website (www.melielomok.com/subscribe/), then put a one-line PHP script (index.php or whatever your site expects the default to be) that accomplishes the redirect, something like this:

    <?php header('Location: http://www.melielomok.com/?p=123'); ?>

    Neither is a good solution, but either should work as a temporary work-around.

    Now excuse me while I slither off in shame for even suggesting such kludges...

  3. MMM-2012
    Member
    Posted 2 years ago #

    Hello and thanks for your support!

    This is my first experience in wordpress.
    I didn't want to use non-pretty permalinks.
    But when I choosed the pretty permalinks options in WP dashboard, for example: Permalink Settings > Post Name, all my images with relative URL (EX. wp-content/images-site/BlockquoteImages_Joyas2012.jpg) show the following: 'The requested URL was not found on this server'. However, links are correctly writted.

    That's the reason I have to use non-pretty permalinks: WP dashboard> Permalink Settings > Default, so I can see all images.

    It's a temporary solution because I didn't understand how to solve the problem.

    Wish I solve this before so the plugin will be ok.

    Thanks you.

Topic Closed

This topic has been closed to new replies.