WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Change Permalink breaks my image links

[Resolved] Change Permalink breaks my image links

  • Hi guys,

    I’m experiencing a problem with WordPress 3.4.2 and the change permalink action.
    I’ll try to give you as many details as I can.

    I’m running the latest version of WordPress 3.4.2 on a linux server.
    My wordpress installation resides in “my-site.com/wordpress” but the home page for the site has been set @ “my-site.com” trough the wordpress settings.

    All the graphics I use for my site have been placed in a folder at the root level so it’s something like “my-site.com/resources” (I don’t like so much the built-in media manager)
    At the moment I’ve got only 4 pages and no post on my site, it’s pretty static.

    I’d like to change the permalink structure from the standard to the “my-site.com/post-name/” one and get rid of the awful post-id permalink.

    The problem is that every time I try to change the permalink structure all my images are not loaded, neither the header nor the background.
    As soon as I switch back to the default permalink structure everything re-starts to work properly.

    How should I handle/fix this?
    I’d like to eventually insert a “news” page but before I’d like to change the permalink structure to avoid any future problems.

    Thanks for the attention.

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Change Permalink breaks my image links’ is closed to new replies.