Support » Plugin: Sessions » Change pages on Active Sessions Management

  • Hi! I have a problem. Having 5 pages of active users I would like to change pages under “Active Sessions Management” (with arrows down on right side of the form of course). But when I click for the next page I have only a white page with this link: about:blank#blocked
    I can only see the first page (even I change from 40 to 80 displayed sessions per page I have the same problem). Everything else works ok. Suggestions? Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hi @piero55… Sorry to hear that. That’s sound very strange, I’m using standard WordPress pagination class.
    Could you tell me: do you have the same issue in pages or posts (in admin view)?

    Thread Starter piero55

    (@piero55)

    No, everything is ok and works normally.

    Thread Starter piero55

    (@piero55)

    By the way: except that, this plugin is wonderful! Congratulations.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Thank you for your kind words…

    I will try to understand what is going wrong; I suspect a security plugin or specific configuration which “jams” the way Sessions construct its urls…

    Could you make the following test : go to the sessions list and when it is loaded, just add &paged=2 at the end of the url (in the url bar of your browser)… Is the second page loading?

    If the second page is loading, my assumptions are right, so before asking what plugins can make this, I have a second test for you: go to the sessions list, hover the > button and copy/paste the url it go to…

    Thanks a lot.

    Thread Starter piero55

    (@piero55)

    Pierre,
    Adding paged=2 (or 3,.4,5..) works ok. No problem.
    Strange thing is that hovering the > buttons I don’t see anything. With Pages and Post I can see the link.
    I analyzed the link (with dev. tools in Firefox pro) and the > shows this code:

    <span class=”screen-reader-text”>Next page</span>
    <span aria-hidden=”true”>›</span>

    Maybe this can help.
    I also deactivated (on staging site) almost all the plugins (security included), switched all the languages to English and removed the Child Theme. The problem is still there.
    Suggestions?
    Thanks,
    Piero

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    What is the <a... tag surrounding these two spans?

    Thread Starter piero55

    (@piero55)

    a class=”next-page button” href=”https://?paged=2&limit=40&#8243;

    and the other is “last-page button”

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    OK. Thanks a lot for this information, it’s very useful.
    On your test site, can you temporarily disable all other plugins to test if it’s better?

    Thread Starter piero55

    (@piero55)

    I did it. I have elementor and a few other activated. I will try to disable everything…
    but it is very strange, because we had really no problem with all the other.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.